Acer Aspire U5-710 - Updating BIOS (HELP!)

Jul 18, 2018
2
0
10
0
Hello Community!

I'm not an expert and have been having trouble with updating the BIOS of my All-In-One Aspire U5-710..

Currently my AIO is running a BIOS version of 'American Megatrends Inc. R01-A1, 26/10/2015'. I went to the Acer website to download the latest BIOS/Firmware Drivers 'BIOS_Acer_R01.A3', however I saw that 5 folders were extracted from the compressed file.

I then called Acer so that they can advise me how to go about installing/updating my BIOS from these files. I was advised to install the .exe that's within both the DOS and WIN folders, once I did this a 'AMI Firmware Update Utility v5.08.00' came up asking me to 'Press any key to continue', I did this twice and the AMI sceeen closed and did nothing..

I'm not sure what's going on, can someone advise please? I'm currently running Windows 10, 64 bit OS.

If you would like more information, please let me know..
 

Lutfij

Splendid
Moderator
Can you parse the SKU for your AIO?
I'm seeing a couple of BIOS updates. You're on A1. I can see A0, A2 and A3. To add, out of the 5 folders, there is one named Appendix. The file named, WinFlash utility will show you how to update your BIOS.

Might I ask why you're trying to update the BIOS? Often times the wrong attempt with the right files can give you a bricked hardware.
 
Jul 18, 2018
2
0
10
0


Hi Lutfij,

From my knowledge, once I opened the 'System Information' Programme, it showed no System SKU number. Is there another way that I can view this?

Ahhh I knew that it could have been something as easy as looking into the WinFlash Utility PDF, I will try this tonight and let you know of the outcome.

The issue that I've been experiencing is that between 15-30 minutes of my AIO being on, I get this constant static noise that lasts for around 30 seconds to 3 minutes, it's a constant sound. I've checked online and read that others have been getting this issue, however from what I've read I seem to have a bit of a different issue, since mine is a constant sound rather than a tapping/screeching sound everyone else is getting.

I'm hoping that this BIOS update will resolve my issue....
 
Thread starter Similar threads Forum Replies Date
GogetaBlue42 Laptop Tech Support 1
J Laptop Tech Support 1
A Laptop Tech Support 4
S Laptop Tech Support 1
F Laptop Tech Support 1
H Laptop Tech Support 1
A Laptop Tech Support 1
xAn9ryM0nk3yx Laptop Tech Support 1
B Laptop Tech Support 13
H Laptop Tech Support 1
A Laptop Tech Support 2
S Laptop Tech Support 2
K Laptop Tech Support 1
M Laptop Tech Support 2
A Laptop Tech Support 1
B Laptop Tech Support 3
S Laptop Tech Support 10
Grigoris0r20r Laptop Tech Support 2
D Laptop Tech Support 1
S Laptop Tech Support 1

ASK THE COMMUNITY