Are Firefox and YouTube a weird combination?

Albionm00n

Estimable
Jan 31, 2016
24
0
4,590
7
I am not sure if I am experiencing a unique issue or if there is anyone who can give me some info on this, but my frustration is mounting:p

My issue is this, whenever I have more than one tab open with youtube, firefox seems to lag severely. For example, it will start to take several seconds for the browser to recognize mouse clicks or typing and even start to have no response issues with only 6 tabs open in a single window. With 32 threads and 64 gigs of RAM, I am a little stumped, for my system should not be experiencing lag like this (it is the only place that I experience ANY issue with my system actually), so I am assuming it has to do with firefox and youtube, for I only get the issue when I have 2 or more tabs of youtube open. I have had literally 3 different windows open with 75+ tabs and will not have this issue until I go to youtube.

Is anyone else experiencing this or have any insight? It is really frustrating...

Thank you in advance for you time and attention to my issue:)

p.s. Firefox also seems to be chewing 14 - 18% of my RAM at this time as well...seems pretty excessive, but maybe that is just Firefox?
 

randomizer

Distinguished
Moderator
Jul 24, 2006
880
0
19,260
62
Ah, you probably don't even have multiprocess enabled. That's interesting. In that case your browser and the tab content shares the same process. That's the way Firefox always worked in the past. I thought everyone had been migrated to at least one content process now, but maybe that isn't being forced until FF 57. Can you install the Add-on Compatibility Reporter addon and check the your addons page to see if it reports any of them as incompatible with multiprocess?
 

Ralston18

Dignified
Moderator
RAM is a possible issue....

Continue watching your system and, in addition to Task Manager, use Performance Monitor and Resource Monitor to further narrow down the possible cuprite or culprits.

Could be some "perfect storm" of things that does indeed only occur with Firefox and YouTube.

Experiment with other browsers and websites while watching the monitors.

You may discover some specific situation that is the root of the lagging.

And try a "build up": i.e., start with one window and add tabs one by one while watching the monitors. Then move to two windows and again add tabs.

You may discover some threshold level that triggers the lag.
 

Albionm00n

Estimable
Jan 31, 2016
24
0
4,590
7
Thank you!

I have been trying most of that already short of using a different browser (I have always used Firefox for its privacy capabilities above other browsers). I have a lot of friends who swear by Chrome, but I have never felt comfortable allowing Google to monitor everything I do...not that I have anything to hide, I just don't like being marketed to and viewed as a commodity, which Google is notorious for. Is there a browser you can recommend that allows me the same ad blocking and privacy settings that I can try? I may try Chrome for a spell just to see if I experience a difference.

Yeah, this has been a weird thing. I have spent at least two months trying to sort it out. I can have my system at max rendering a 3D image (32 threads at 100%) and still be able to multitask in other programs and apps without issue...this is the only time I experience any slow down or lag. I also have a feeling that Firefox is potentially not well optimized and hogs RAM resources naturally, but having not used another browser to compare to, this may just be the norm for internet browsing?

Thank you for your response!

 

randomizer

Distinguished
Moderator
Jul 24, 2006
880
0
19,260
62
Is it responding slowly within the web pages only or even for things like the address bar? I'd be surprised if the browser itself was significantly impacted, but it's quite possible for the web pages to become unresponsive if another is resource-heavy. The current stable release of Firefox (56) still uses a single process for all tab content, but a separate process for the browser itself. Chrome uses a process per site visit (roughly) which provides reasonably good resource isolation, but it comes with significant memory overhead. FF 57 will share tabs between 4 processes by default (except on lower end machines) as a compromise between memory usage and responsiveness.

Assuming you're using the current stable release, you can try increasing the number of processes to see if it resolves your issue. Open up the Options page and scroll down to the Performance section. Uncheck "Use recommended performance settings" and then change the number of content processes to 4 instead of 1. You can set it higher if you want, but note that each process adds memory overhead as a trade off for more tab isolation. Probably check that "Use hardware acceleration when available" is also enabled.
 

Albionm00n

Estimable
Jan 31, 2016
24
0
4,590
7


Greetings!

Thank you for such a precise and explanatory response! To answer your question, everything slows down. I will literally have to wait around 2 - 5 seconds for any action. For example: When you hover your pointer over a tab, as you know, it will highlight, which will then allow you to actually click the tab (I have found that you are not allowed to select the tab until it highlights). Well, I will have to wait that 2 - 5 seconds just for the tab to highlight...then when I click the tab, it will take that same time to register the click and show me that page. Literally every single action within usability is delayed...The browser as a whole, include responsiveness of the web pages themselves.

I have taken your advice and direction and went into options and made the changes...except that changing the number of processes was not available...it is there, but I can not make any changes (it is the default grey of an non select-able item). I am fully updated for FF 56.0.2, but below the process number selection text it reads:

"Modifying the number of content processes is only possible with multiprocess Firefox. Learn how to check if multiprocess is enabled"

With the last sentence being a link. I clicked the link and it took me to a Mozilla page that reads:

"Repairs in Progress
The service you’re looking for is unavailable at the moment. We’ll be back up and running again before long, so please try again soon. Thanks for your patience!"

So, I will watch to see if there is any improvement with the other changes you recommended (I currently do not have any Youtube tabs open at the moment, so everything is running smooth, but I will test) and definitely give you the solution credit to take the post off the active forum (and as thanks of course), and maybe I will be able to change the process number at some point soon to see if that helps as well. As you can see from my specs below, I have plenty of overhead for RAM, so if bumping it up eventually to more than 4 processes can make a difference, I have no concerns there. This potential FF/Youtube lag weirdness is literally the only such symptom like this that I have experienced since I built the system a year ago...I can be taxing all 32 threads with a 3D render and still multitask with Sketchup, Firefox (without Youtube as far as I can tell), and other apps/programs without issue.

Thank you again for your awesome response Randomizer!
 

randomizer

Distinguished
Moderator
Jul 24, 2006
880
0
19,260
62
Ah, you probably don't even have multiprocess enabled. That's interesting. In that case your browser and the tab content shares the same process. That's the way Firefox always worked in the past. I thought everyone had been migrated to at least one content process now, but maybe that isn't being forced until FF 57. Can you install the Add-on Compatibility Reporter addon and check the your addons page to see if it reports any of them as incompatible with multiprocess?
 

Albionm00n

Estimable
Jan 31, 2016
24
0
4,590
7


Yes!!! You nailed it on the head. I added compatibility reporter and saw that indeed I had two add-ons that were a little old and were not allowing multi-processing. I easily found compatible replacements for those add-ons, and voila! Multi-processing enabled. I set it up to the maximum of 7 and have been running a load test for the last hour with multiple windows, a bunch of tabs with multiple (like 20) different youtube tabs open. Everything is running butter smooth and I have seen little to no noticeable increase in RAM usage...still ranging around the 16% average.

Thank you very much for your sharing of knowledge, you totally solved this conundrum for me!
 

randomizer

Distinguished
Moderator
Jul 24, 2006
880
0
19,260
62
And we didn't even need to delve into about:config. Glad to see it's working well now. Take note of any addons tagged as "Legacy" as well (the compatibility reporter isn't required for this). These won't work in FF 57 because the old extension APIs are being removed, so you might want to research if they're going to be updated, or search for replacements.
 
Thread starter Similar threads Forum Replies Date
Kisianik Apps General Discussion 4
S Apps General Discussion 1
P Apps General Discussion 1
T Apps General Discussion 3
J Apps General Discussion 6
Darkmatterx Apps General Discussion 3
A Apps General Discussion 7
R Apps General Discussion 5
R Apps General Discussion 10
Tigro Apps General Discussion 3
H Apps General Discussion 2
TeaSponge Apps General Discussion 1
D Apps General Discussion 9
E Apps General Discussion 1
J Apps General Discussion 5
C Apps General Discussion 2
C Apps General Discussion 1
J Apps General Discussion 9
akaikisaki Apps General Discussion 6
M Apps General Discussion 2

ASK THE COMMUNITY

TRENDING THREADS