Asus K55N power problem

NYOS87

Distinguished
Feb 21, 2011
2
0
18,510
0
Hello. So I've been having problems with my laptop's power of late.

When I connect the charger both the orange charging indicator and the green light on the AC adapter blink. If I take out the battery the charging light doesn't even flash and the computer does not power on.

I've found that it does charge, but it charges extremely slow. I left it on the charger for about 8 hours and it had only gone up to 14% from 0% before I had left it to charge. After that I powered it on and saw there was no charging indicator on the battery icon within the OS.

I opened up the laptop to check if there was anything wrong with the cables, didn't see anything that really stood out. I uninstalled/reinstalled the ACPI drivers, but that didn't do anything.

And if it helps the problem started after I repeatedly turned it on and off trying to access the boot menu. Pretty sure I may have messed it up :(
 

NYOS87

Distinguished
Feb 21, 2011
2
0
18,510
0
Shouldn't it at least be able to power up with just the charger? I've used it like that before, but it doesn't work like that now.
 
Thread starter Similar threads Forum Replies Date
JLMU Laptop Tech Support 1
P Laptop Tech Support 0
A Laptop Tech Support 0
Mohamedd123 Laptop Tech Support 1
chkontog Laptop Tech Support 0
S Laptop Tech Support 1
joyesmoke Laptop Tech Support 1
A Laptop Tech Support 1
C Laptop Tech Support 5
DariusEldritch Laptop Tech Support 0
Tania500 Laptop Tech Support 1
hikswolf Laptop Tech Support 0
Kirstie_P Laptop Tech Support 3
C Laptop Tech Support 5
R Laptop Tech Support 1
N Laptop Tech Support 1
N Laptop Tech Support 2
E Laptop Tech Support 1
W Laptop Tech Support 3
T Laptop Tech Support 2

ASK THE COMMUNITY