Question ASUS ROG GL553VW not booting up after shutdown.

Oct 3, 2020
4
0
10
0
My laptop is not booting up after the shutdown. The issue is pretty weird; when I remove the battery and boot it up with AC adapter only, it works fine.
Test Cases I ran:
  1. With Battery, not working at all.
  2. With AC adapter and Battery both attached, don’t work at all.
  3. With only AC adapter attached and battery removed, works fine.
I've tried with different adapter and new battery but still the same results.
Any help would be appreciated.
 
Oct 3, 2020
4
0
10
0
About all that is left is the power supply/switching circuitry on the motherboard. I think it's a pretty safe bet something is defective there. Sorry--that's not much help!
I checked that too. Couldn’t find any defect there.
btw I changed the charging IC and now the battery is detected atleast.
 
Oct 3, 2020
4
0
10
0
Wow--you are digging deep. Sorry I have no more advice to offer! I suspect you are on the right track.
Yeah. Another hurdle is the unavailability of schematics for the board. I only found the boardview which is somewhat helpful but not much. That’s why I posted on forums is someone had the same issue.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 2
live_neutral_ground Laptop Tech Support 0
G Laptop Tech Support 6
AstroAvocado Laptop Tech Support 3
CapNemo Laptop Tech Support 4
taizai Laptop Tech Support 1
T Laptop Tech Support 2
S Laptop Tech Support 1
NicIsHere123 Laptop Tech Support 6
T Laptop Tech Support 1
S Laptop Tech Support 2
D Laptop Tech Support 0
M Laptop Tech Support 9
D Laptop Tech Support 0
vlahos Laptop Tech Support 0
ooof.u Laptop Tech Support 0
A Laptop Tech Support 7
Tanyalin Laptop Tech Support 1
Josip975 Laptop Tech Support 20
H Laptop Tech Support 3

ASK THE COMMUNITY