Asus U56E Power problem


Nov 19, 2013
I'm working on an Asus U56E for a friend. I'm having problem getting power to the laptop to run or charge the battery.
I know the power adapter is good, as it's putting out 19.5 VDC. But, when I plug the adapter into the laptop (without a battery installed), the laptop won't power on.
So, I verified that it WASN'T the power port, and verified that I am getting 19.5 VDC on the motherboard side of the power port. With a battery installed, the laptop will power up and work properly. However, the battery is not getting a charge current, from the laptop.
Finally, the last time the entire unit worked properly, (meaning the battery was accepting a charge from the laptop), the power adapter got really hot.
I suspect that the DC/DC converter on the motherboard may have given up, resulting in the need to replace the motherboard. But, would like other thoughts on this problem.


Nov 25, 2013
Exactly same problem here with asus k70af ..
it stops before post.. i can hear hdd spinning up then i noticed that all controls flashed off and on and then again . and wont start...
i tried another disks, rams , chargers,, without battery .. i even took out rams and gpu .. and no beeep sounds from POST announcing missing RAM...i literally tried every possible solution or way to find the cause...
even charging light isnt on when battery is in and it is not charged battery .. i tried other chargers, (of course suitable for nb),
to me it seems like there is some power supply or MB hardware problem, probably in that module which is directly conected to charger connector .. .... thats my conclusion .
any new info about this problem?