BIOS wont detect SSD

Degk

Estimable
Jul 29, 2015
3
0
4,510
0
I've installed a new mSATA SSD to my laptop (msi ge60). I have cloned the SSD and now I can see it as disc A (https://i.imgur.com/2egjZI4.png). Now in order to continue with the process of making SSD my main disc I need to prioritize it over my HDD in the BIOS and here where the problem is. I can not find it the BIOS what so ever (https://i.imgur.com/QNGw5KS.jpg). I was looking for solution everywhere, but nothing seemed to help
Things that I've already tried)
-Starting laptop with SSD only
-Switching to Legacy mode and choosing my SSD after restarting my computer
-Cleaning the SSD and cloning it again
-Replacing SSD into other SSD socket
-Starting windows using advanced boot options (https://i.imgur.com/Lp34NWD.jpg)

My OS is Win 8, BIOS version is E16GAIM.510

Any help will be highly appreciated and I'll gladly answer your questions.
 

Barty1884

Admirable
Moderator
When you cloned to the SSD, was it AHCI enabled...or are you attempting to enable after the fact?

If you're doing it after the fact, it's probably a good thing you're on W8 as W7 was a nightmare.

Put your BIOS back to IDE and boot.

Go to Registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride
Change the 0 DWORD value from 3 to 0.
Reboot, and change your SATA controller to AHCI in BIOS.
 

Degk

Estimable
Jul 29, 2015
3
0
4,510
0
EDIT: I've tried to run in legacy mode once again, and now I could choose my SSD in BBS options, however whenever I tried to start windows in this mode this is what it showed https://i.imgur.com/VFksknJ.jpg . Once I switched to UEFI mode all I could see in BBS options was windows boot drive.
 

Degk

Estimable
Jul 29, 2015
3
0
4,510
0

Yes, I have, but when I enable it option to choose my SSD disappears.
 

Barty1884

Admirable
Moderator
When you cloned to the SSD, was it AHCI enabled...or are you attempting to enable after the fact?

If you're doing it after the fact, it's probably a good thing you're on W8 as W7 was a nightmare.

Put your BIOS back to IDE and boot.

Go to Registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\StartOverride
Change the 0 DWORD value from 3 to 0.
Reboot, and change your SATA controller to AHCI in BIOS.
 
Thread starter Similar threads Forum Replies Date
tweeds Laptop Tech Support 3
lucasblack29 Laptop Tech Support 1
R Laptop Tech Support 8
A Laptop Tech Support 0
Secritek Laptop Tech Support 3
aztrovoi Laptop Tech Support 6
Maxwell902 Laptop Tech Support 1
R Laptop Tech Support 1
S Laptop Tech Support 3
baakudai Laptop Tech Support 5
I Laptop Tech Support 0
Atharva1313 Laptop Tech Support 0
A Laptop Tech Support 1
Kingpizza Laptop Tech Support 5
W Laptop Tech Support 1
T Laptop Tech Support 2
T Laptop Tech Support 5
newbie_techie Laptop Tech Support 6
N Laptop Tech Support 3
C Laptop Tech Support 17

ASK THE COMMUNITY