COMPAQ PRESARIO NO POWER AND CHARGING ISSUE

wasekhan

Distinguished
Sep 22, 2006
12
0
18,560
0
compaq presario cq40 not switching on and no power and charging,not even power led is blinking which is integrated in power jack..i took a visual look there is one burned capacitor near battery connector i changed that but stil laptop is in same condition.can anyone plz tel me that how to find and fix a fault is laptop dead,i m a poor guy and earn money by repairing computers this is a only way to earn money for me...plz sumone help me i will be really very thankful to him..
 

HeyItsBob

Distinguished
Sep 14, 2011
3
0
18,510
0
That would probably indicate a bad charger.

If you had a separate power supply you could test this. You can order an OEM replica from amazon for a pretty good price typically.

To test this, you could use a multimeter to see if your getting a charge from it. Just use the black contact on the outside of the metal and touch the inside of the charger plug with the red contact.
 

wasekhan

Distinguished
Sep 22, 2006
12
0
18,560
0
ya i have checked the charger with multimeter,charger giving right voltage i.e 19v,13v and also checked the mother board,mobo getting charge from it but not passing it to other component,i capacitor was burn so i changed that but so result,i m posting the picture of mobo that will help u to understand the whole story
 

wasekhan

Distinguished
Sep 22, 2006
12
0
18,560
0
i checked it with new battery,laptop turn on and charging light also start bilinking,but the light is only blincking when laptop is on after turnoff light also goes off and without batter laptop is not turning on i mean i cant turn it on by direct power supply only
 

wasekhan

Distinguished
Sep 22, 2006
12
0
18,560
0
i checked it with new battery,laptop turn on and charging light also start bilinking,but the light is only blincking when laptop is on after turnoff light also goes off and without batter laptop is not turning on i mean i cant turn it on by direct power supply only
 

wasekhan

Distinguished
Sep 22, 2006
12
0
18,560
0
no ac adapter is not a problem i tried new adapter one of my friend,is there any ic in motherboard for charging a battery or any power ic if yes thn plz tel me how to test that with digital multimeter or another way to check that ic is working or not..
 

sachin_28

Honorable
Apr 24, 2012
1
0
10,510
0





pls change the bios of cq40 your problem will be solved


sachin 9358687233
 

christofer19

Honorable
Apr 15, 2013
1
0
10,510
0



sir, me too got the same problem, does changing the bios solve this?. the bios ic or just the battery? huhu, i'm so noob in repairng.

 

creamtown

Honorable
Oct 9, 2013
1
0
10,510
0
hi @cristopher, have u solved your problem. I just got the same problem. My hp compaq cq40 went blank screen, fan sounded really load then stopped working until now, the num/caps lock blinking once every 3 seconds, dvd is making sound.
 
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 3
K Laptop Tech Support 1
T Laptop Tech Support 2
A Laptop Tech Support 1
R Laptop Tech Support 1
D Laptop Tech Support 4
J Laptop Tech Support 11
D Laptop Tech Support 3
J Laptop Tech Support 1
P Laptop Tech Support 1
Anna Marchetti Laptop Tech Support 2
E Laptop Tech Support 1
A Laptop Tech Support 2
P Laptop Tech Support 1
L Laptop Tech Support 1
L Laptop Tech Support 4
S Laptop Tech Support 3
S Laptop Tech Support 1
E Laptop Tech Support 1
M Laptop Tech Support 3

ASK THE COMMUNITY