Question CPU Stuck at base frequencies

May 18, 2020
1
0
10
0
ive tried everything, i have throttlestop, ive set my start in regedit to 3 and 4, i have changed my power plan to high, ive done everything i could scour the internet of.

heres my current laptops specs

Dell Inspiron 15 7000
Intel(R) Core(TM) i5-7300HQ CPU @2.50 GHZ
16 GB of ram
Nvidia Geforce gtx 1050

heres a screenshot of my throttlestop
 
May 19, 2020
1
0
10
0
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\intelppm
Start should be set to 3 in that registry key.

Your screenshot shows that SpeedStep is disabled. Check that box and check the Set Multiplier option. That should help.

Better yet, go into the TPL window and enable Speed Shift. This is the preferred method to control CPU speed on a modern Intel CPU. When Speed Shift is enabled, you will see SST in green on the main ThrottleStop screen. Now you can check the Speed Shift - EPP box and set EPP to 0 for maximum performance or set it to 80 for something similar to the Balanced power profile.

If you are going to use Speed Shift, you do not need to check SpeedStep or Set Multiplier. Choose one CPU control method or the other. No need to choose both.
 
Thread starter Similar threads Forum Replies Date
D Laptop Tech Support 1
RamanMistri Laptop Tech Support 0
dietherdeyv Laptop Tech Support 0
P3T2 Laptop Tech Support 2
Matiyo Laptop Tech Support 0
K Laptop Tech Support 3
JackGer8 Laptop Tech Support 0
T Laptop Tech Support 0
Purestrafe Laptop Tech Support 0
K Laptop Tech Support 2
T Laptop Tech Support 0
D Laptop Tech Support 1
M Laptop Tech Support 2
A Laptop Tech Support 0
C Laptop Tech Support 1
Kapuhy Laptop Tech Support 2
K Laptop Tech Support 0
ClareJohnston Laptop Tech Support 1
K Laptop Tech Support 0
K Laptop Tech Support 0

ASK THE COMMUNITY