Question Dell Latitude D531 fan problem

Desire1503

Great
Feb 18, 2022
33
2
85
4
Hello. I have a problem with another laptop, a Dell Latitude D531. I tried Windows XP, Vista and also 7, but the fan is not spinning as it should.. When I start the laptop, it spins at fast speed for few seconds, then it stops. When I get into Windows, there's no spinning at all..
I cleaned it, but nothing.
I updated BIOS and it was strange because while it was updating, the fan was spinning at maximum speed. But after finishing updating, it stopped spinning.
I checked the wires, everything's fine.
The charger has 19.5V, so it's ok.. I don't know what to do anymore, any ideas?
 

mr_random

Great
Feb 28, 2022
37
0
80
0
lose wire? the heat expansion on the board could cause the leads or pins to connect and that could make it work while it's getting hot
 

Etrius vanRandr

Upstanding
May 11, 2022
212
31
360
0
Hello. I have a problem with another laptop, a Dell Latitude D531. I tried Windows XP, Vista and also 7, but the fan is not spinning as it should.. When I start the laptop, it spins at fast speed for few seconds, then it stops. When I get into Windows, there's no spinning at all.
I had this issue with a D620. Pretty sure it's a BIOS issue that Dell never patched. On the D8xx it works fine but the D6xx and D5xx it doesn't.

The D531 is an ancient relic, Indiana Jones would love to put it in a museum. Not sure what you're going to be using it for, but that laptop is older than most highschoolers.
 
Thread starter Similar threads Forum Replies Date
paqkr Laptop Tech Support 3
Walid_bb Laptop Tech Support 1
F Laptop Tech Support 3
S Laptop Tech Support 1
S Laptop Tech Support 1
J Laptop Tech Support 2
G Laptop Tech Support 18
D Laptop Tech Support 2
A Laptop Tech Support 2
T Laptop Tech Support 5
X Laptop Tech Support 4
P Laptop Tech Support 4
L Laptop Tech Support 1
M Laptop Tech Support 1
Boris_yo Laptop Tech Support 1
E Laptop Tech Support 10
C Laptop Tech Support 1
A Laptop Tech Support 1
T Laptop Tech Support 2
M Laptop Tech Support 1

ASK THE COMMUNITY