Desperate looking for help :( - My laptop keeps using Intel graphic card

Not open for further replies.


Aug 7, 2015
Hello everybody,

I'm desperate looking for help with the following problem:

Today I received my Lenovo Y50-70, and the first thing I did was installing GTA IV so I can play it with mods.
I opened the game, and went to the graphic section, and it says that it doesnt have enough video memory.
I've a GeForce GTX 960M in the laptop, and I looked online for some answers.
I found out that the game is running on the Intel 4600 graphic card so I tried some things that helped other people out:

1: Run with high performance
When I try to run the game with high performance, I get a error:
you don't have the privilege to select the graphics processor in this menu

2: Disable Intel inside the Bios menu
I went into the Bios setup and that isn't even possible, I can disable my GeForce but not the Intel video card.

3: Disable Intel inside device manager
When I did this it even gets more worse, the game couldn't run because it needed directplay.

4: Update the video card drivers from Nvidia
Yeah, I can repeat it again, it isn't working.

5: Connect my laptop with the HDMI cable to my TV
I read something about this on a forum but still nothing.

I'm really desperate, and I can not tell possibly how grateful I am to the one who solves this.




I just read somewhere to add -launch in the shortcut, and uncheck run as administrator.
I did that and pressed run with high performance graphic processor, and the game started, however the game still says that there is not enough video memory
Not open for further replies.