Disappearing connection in FF

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
For like a month I've been suffering from a weird occurrence that's driving me completely insane. Namely, the connection in my Firefox tends to disappear because of no apparent reason. I'm just browsing the Net and BAM, the connection either disappears and I have to close Firefox and run it again (meanwhile all other Net-based apps are working fine) or the connection speed is dropped by such an amount that it takes like a minute or more to get to a text-based site and then it starts to behave normally. I don't have a slightest clue what could have caused this - started happening just like that, I can't recall any apparent reason. From what I see, Flash players tend to make the process faster - but it also depends. On YouTube, I can run a few tabs simultaneously and nothing bad happens while two clips on CollegeHumor are enough to stop the connection inside FF and make my restart it. There is also a Polish website which stops the connection EVERY-TIME. Five, six links clicked and here we go. It doesn't matter if I'm multi-tabbing or not. It happens on no other device connected to the router. And in case that matters: Windows 7 here. Could you please help me identify the villain?
 

nikorr

Distinguished
Moderator
"Firefox may show a Server not found or Unable to connect error message." Is this what are u getting?

Can u try to pause your Antivirus and than start FF and check if it is still going on.
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
Nope, I have no message prompted, it just loads the website infinitely without any element of it being actually loaded.

Pausing AV doesn't change a thing, regretably...
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
Oh, by saying I paused AV, I meant I paused both, sorry for misunderstanding.

And no, I don't recall having blocked any scripts. Turning Ad-block off doesn't help either.
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
It starts to happen more and more frequently. Entering DeviantArt is impossible - the connection stops without even showing any of the thumbnails - only the text and hollow boxes appear and then BAM, everything's gone... I'm clueless.
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
None of these happens while running Chrome. Tried disabling all plugins and addons, no change.

What stroke me as odd, after a little thought, is that every first time I start Firefox after turning on the PC, after a little browsing Norton gives me a prompt that RadioWMPGecko19.dll was scanned and is safe. It's a little weird it lets me know this EVERY-TIME, isn't it? After googling, I know that it may be malware but a) Norton doesn't agree, b) Malwarebytes Anti-Malware either. What then?
 

mrmaia

Distinguished
Aug 9, 2011
154
0
18,640
1


Looks like malware. Check this out.
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
Yeah, that's the site I said I had googled a while ago.

I checked the directory Norton told me it had been in - there were five RadioWMPGecko-es, each with a different number in the end. I deleted all of them and see no difference in Media Player embeds so I don't know what this was..

I'd rather not use any anti-malwares like SuperAntispyware. The name of it and the website alone make me feel there are more malwares bundled than I'll probably be able to get rid of..
 

mrmaia

Distinguished
Aug 9, 2011
154
0
18,640
1


LOL exactly what I think about such programs!

And erasing all those files worked?
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
Not really. Something changed today, though - up until today getting on deviantArt, for example, always resulted in what I descripted above. No image loaded, connection lost, has to restart the browser. Today, though, it loads half of the thumbnails and even though it won't move from there and all other tabs won't load, if I close the tab with loading dA, the connection comes back and I can browse normally. Same with eBay auctions filled with many high-res pictures.

And just in case someone wanted to point me out lameness: no, it's not that my connection speed is just low :D
 

mrmaia

Distinguished
Aug 9, 2011
154
0
18,640
1


Oh, some progress!

Now try uninstalling FF with this in Advanced Mode and deleting everything on the way, then reinstalling it.
 

aford10

Distinguished
If you think you have malware, which it sounds like you do, that's a good place to start. There is a malware guide in my signature to help rid your system of that. And yes, superantispyware is a safe and quality program.

What version of FF are you on? And if you're on the newest version, then at least uninstall it, and reinstall it.
 

Tigro

Distinguished
Jun 16, 2009
21
0
18,560
0
OK, did all you descripted in your guide. DeviantArt loaded with all the thumbnails though right after that the connection stopped and I had to restart the browser to load any other site. Small step for a man, giant leap for the mankind :D

Reinstalling FF? Well, doesn't seem too likely it would fix anything to me, though I'll do it if nothing else comes to our minds. Seems it wasn't malware then, yep? I mean, Malwarebytes found some 15 malwares, CCleaner found some 500 bad registry entries (haven't heard of a workstation it did not found something on.. ;)) and Spybot found 7 problems. They solved everything but, as you can see, it didn't actually help. Do you have any other ideas?
 

nikorr

Distinguished
Moderator

Nope. It could be something that cannot be fixed by any registry cleaners.
 

nikorr

Distinguished
Moderator


After the uninstall, use CCleaner and than install.
Back up FF with MozBackup, as u should regularly, and make two back ups.
1. Profile with bookmarks
2. Profile with bookmarks with add-ons.
3. Re-install
--------------------
It takes about 3minutes.

http://mozbackup.jasnapaka.com/
 
Thread starter Similar threads Forum Replies Date
H Social Networking 1
S Social Networking 1
I Social Networking 0
Wval0700 Social Networking 2
Hordofa Jemal Social Networking 1
O Social Networking 2
D Social Networking 2
A Social Networking 5
F Social Networking 4
E Social Networking 2
B Social Networking 1
G Social Networking 1
C Social Networking 2
M Social Networking 2
I Social Networking 1
I Social Networking 3
crossfiresli160 Social Networking 1
M Social Networking 1
R Social Networking 3
C Social Networking 2

ASK THE COMMUNITY

TRENDING THREADS