Does Not Power On Lenovo N580

talkdotcom

Estimable
Apr 13, 2014
12
0
4,560
0
Recently replaced keyboard and a cracked LCD Screen. Put back together and now laptop is dead. I tried all that emptying cache stuff and that didn't work. Please help.
 
NOTE: Yes, I know some batteries are not so easy to get to, on some devices. However, it should be removable/replaceable. Unless it is under warranty, then you should contact the manufacturer first.


Try the following and see if it will turn on...

1. Unplug your charger cord.
2. Remove the battery.
3. Press and hold the "Power" button for 30 seconds.
4. Now plug back in the power/charger cord.
5. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop. You may also want to try charging it when the device is off, rather than on. If it works then, the cord is probably the issue.

Should that not be the problem, then check the battery to see if it needs replacing.

 
NOTE: Yes, I know some batteries are not so easy to get to, on some devices. However, it should be removable/replaceable. Unless it is under warranty, then you should contact the manufacturer first.


Try the following and see if it will turn on...

1. Unplug your charger cord.
2. Remove the battery.
3. Press and hold the "Power" button for 30 seconds.
4. Now plug back in the power/charger cord.
5. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop. You may also want to try charging it when the device is off, rather than on. If it works then, the cord is probably the issue.

Should that not be the problem, then check the battery to see if it needs replacing.

 

talkdotcom

Estimable
Apr 13, 2014
12
0
4,560
0


 

talkdotcom

Estimable
Apr 13, 2014
12
0
4,560
0
I checked everything I touched related to the keyboard connection and the new lcd screen. There is still a green power light on the front side of the laptop. HOWEVER, the socket for the power cord wiggles and is lose. Wires do not appear to be broken, but I'm thinking this has to be the issue. What do you think?
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 0
M Laptop Tech Support 1
O Laptop Tech Support 1
plouat Laptop Tech Support 0
F Laptop Tech Support 3
R Laptop Tech Support 5
pixellegolas Laptop Tech Support 1
jonbremont Laptop Tech Support 6
MarleT Laptop Tech Support 0
A Laptop Tech Support 1
ShravanM Laptop Tech Support 10
roystons Laptop Tech Support 0
nerdyotter Laptop Tech Support 0
Jewelsfaye Laptop Tech Support 0
D Laptop Tech Support 0
celassad Laptop Tech Support 3
P Laptop Tech Support 8
J Laptop Tech Support 1
ionutdragos Laptop Tech Support 1
nivedn3 Laptop Tech Support 0

ASK THE COMMUNITY

TRENDING THREADS