Dx8+Athlon+Geforce2 problem!




Before my complaints, see my specifications:

- Athlon classic 650MHz (slot A)
- Mobo ASUS K7M (chipset AMD751 + VIA VT82C686A)
- ASUS v7700 Geforce 2 GTS Pure 32MB
- Windows 98 SE
- Directx 8.0a (Actually using Dx7a)
- SBlive
- 128MB RAM
- Nothing overclocked!

I'm using the latests AMD agp drivers and via 4 in 1.

The problem is: When I run applications that require D3D, like the playstation emulator ePSXe, it crashes, and the only solution is to reboot the PC! Then, I've unistalled the Dx8 and have reinstalled the Dx7a, and all the problems were resolved! Great, but I need to run some Dx8 applications, I need resolv this abnormal behave with Dx8! And before you say me to reinstall win98, I've just did it (HD formatted!) and nothing has changed, it can't resolv my problem. Help me!

ps: It only occurs with this Geforce 2, my old card (voodoo3) works flawless with dx8 in this same system! I've tested dx8 and dx8a!


Hey Hyllian,
I'm currently having the same problems. My config is pretty much the same as yours and I'm having pretty much the same problem. Here's a list of what I have in my box:

AMD Thunderbird 850Mhz processor
Skyhawk 300W power supply
Maxtor 13.5 GB HD (7200 RPM ATA 66)running on Primary Master ATA 100 IDE channel
Maxtor 6.7 GB HD (5400 RPM ATA 33)running on Secondary Master IDE channel
Kenwood 52x CDROM
256MB's of Micron SDRAM
MSI StarForce 815 (GeForce 2) AGP video card (32MB's of DDRAM)Using the latest NVIDIA Detonator drivers Det ver 3 (Release 6)
Sound Blaster Live X-Gamer 5.1 sound card (utilizing Liveware ver 3.0 software/drivers
MS Laser Optical mouse (MS Intellipoint 3.2 mouse drivers)
Dual Boot of: Win2K & Win98SE OS (Utilizing DirectX 8a)
Using the latest 4 in 1 AMD AGP drivers
Bus Mastering drivers for the KT7A-RAID are installed
No third party system utilities installed
Currently running NetBoost 2001 for an MTU optimizer
Saitek X36F Joystick combo (throttle and Joystick) using SGE version 2.3 for the driver/stick setup program.

Now, I've been at this troubleshooting session for about the past 2 months. Like yourself I've pretty much tryed everything in the book as it were. My latest attempt that I'm going to try however is an old addage that my older brother used to beat me over the head with it goes like this.."if all else fails..read the intructions"..long and the short..I'm going to follow NVIDIA's documentation about "UNINSTALLING" the previous drivers of theirs and then installing the new ones. You see, they have in their documentation that I had for some of my older NVidia based cards that said with a big fat emphasis of the following:

Prior to installing the new drivers, make sure you go to control panel>Display Icon>Advanced button>Click on Adapter tab> click on list all display devices> choose PCI-VGA as the adapter setting>> click ok>> Click ok>> when the message "Do you want to restart your computer" choose yes...
Computer restarts...perform the above all over again ...except this time when you tell it to list all display devices..tell it you "Have disk" and then point it to the directory that you have the "decompressed" Nvidia drivers and choose the one that suits your particular cards needs..

I seem to remember from back in my Riva 128 and Velocity 4400 day's that if you didn't do it this way with an Nvidia chipset based video card..you were pretty much to expect what me and you and several others that I've noticed have so frustratingly encountered...I'll try this and get back with you on this attempt...:)


Motivation is half the battle to success..personal intiative completes the process..:)


Well, I tryed that recent possible fix I spoke of. No dice..:( However just to satisfy my suspicions about it being OS related and not Hardware, I ran a scandisk check in the Windows 98 (SE) environment and it would hang about 3/4th's the way through the scan. I then tryed the scandisk check out in the DOS environment through a cold boot into the DOS prompt. No hang-up's there...YEAH!..so, that isolated it down to the OS environment as far as that goes. The one thing I've been noticing throughout many similar post's is that we all have a GeForce 2 GTS series chipset (different manufacturers but the same chipset) and we're all running pretty much the same software with just slight variations here and there. I've summized the following similarities about all of our respective systems (mind you this isn't conclusive)

1. Running DirectX version 8.0 or 8.0a
2. Using GeForce 2 GTS series type video cards
3. Running for the most part, NVidia's latest Detonator drivers (ver 3.0)
4. Running the latest Via 4 in 1 driver set
5. Via KT133 chipset's (be they Abit, MSI, Asus, etc..etc) usually the K7 series
6. Athalon Proccesors (650Mhz on up..my processor is an 850Mhz)

I went to Nvidia's support section for some possible help on the video card side of the lock-up issue and they explicitly state that it's the responsibility of the video card manufacturer to satisfy the technical problems with their repsective card they sell for tech support. Surfed Via's web site (still checking that one out) and nothing resembles our problem to much there. Checked HighPoints site for possible issues being mentioned there (for you RAID MB owners) about this problem and no dice there either. Sound Blaster is still kicking out the Liveware 3.0 with no changes there (I went there because I thought that it may be a sound card driver issue). AMD has not seen any flack from their side of the fence as far as I could tell in this problem. So, that narrows it down to Microsoft's latest drivers DirectHex 8 (don't mind the pun..:) Now I'm sure it wasn't the intent of the DX8 developers to hang up we AMD/K7 users but it seems to be the resounding statement of all frustrated users in this category.
My next attempt (or experiment) is to go with a fresh install with 98SE with only DirextX ver 7 installed and all of my games that don't need to use DirectX 8 and see if I incur the same lock-up sitution. I will post my findings when I'm done. In the mean time...wish me luck..:)


Motivation is half the battle to success..personal intiative completes the process..:)


Jan 25, 2001
i dont have a geforce, i have an aiw and to install the latest drivers for it i had to install dx8. after doing this though, my computer wouldn't go to windows. dx8 is definetely buggy. i am just glad i backed my hard disk up.

hail the holy norton ghost
Thread starter Similar threads Forum Replies Date
P Apps General Discussion 0
Z Apps General Discussion 0
M Apps General Discussion 0
W Apps General Discussion 2
B Apps General Discussion 0
paymanz Apps General Discussion 0
R Apps General Discussion 3
Scrob07 Apps General Discussion 0
F Apps General Discussion 5
J Apps General Discussion 0
P Apps General Discussion 4
I Apps General Discussion 3
kikani.kautik Apps General Discussion 2
synoptic12 Apps General Discussion 3
XtremeAero426 Apps General Discussion 6
C Apps General Discussion 1
L Apps General Discussion 2
G Apps General Discussion 4
C Apps General Discussion 7
G Apps General Discussion 6