Solved! Extremely low FPS in games

Dec 11, 2020
3
0
20
0
Hello, I have purchased my laptop about a year ago. All the games played fine in the first few months. But eventually the FPS started dropping bit by bit. Games like Rust, COD cold war, COD MW and even FiveM (GTA V) all run at about 13FPS and drop to 5-0FPS a lot. I play on the lowest settings and 1280 x 720 resolution to reduce even more FPS lag.

My specs are:

Intel core I7-9750h
RTX 2070 max Q - 8GB
16GB DDR4

I've tried overclocking, running the fans at max speed, resetting the pc, scanned for faulty hardware all with no result. (I play with the laptop plugged in)

Maybe someone can help or tell me what is wrong?
Many thanks,
-Jannick
 

Deciplox

Great
Dec 8, 2020
57
1
85
0
Hello, I have purchased my laptop about a year ago. All the games played fine in the first few months. But eventually the FPS started dropping bit by bit. Games like Rust, COD cold war, COD MW and even FiveM (GTA V) all run at about 13FPS and drop to 5-0FPS a lot. I play on the lowest settings and 1280 x 720 resolution to reduce even more FPS lag.

My specs are:

Intel core I7-9750h
RTX 2070 max Q - 8GB
16GB DDR4

I've tried overclocking, running the fans at max speed, resetting the pc, scanned for faulty hardware all with no result. (I play with the laptop plugged in)

Maybe someone can help or tell me what is wrong?
Many thanks,
-Jannick
Hi,

Have you updated your GPU drivers?

If you was previously getting higher frame rates and you have not made any significant changes to your system, id say something is running in the background which is eating up the resources needed to run the game.

Also id double check your laptop has not auto changed to the iGPU (intel HD) instead of the dedicated one (2070). You can do this via your driver settings.

Thanks
 
Dec 14, 2020
1
0
10
0
Hello, I have purchased my laptop about a year ago. All the games played fine in the first few months. But eventually the FPS started dropping bit by bit. Games like Rust, COD cold war, COD MW and even FiveM (GTA V) all run at about 13FPS and drop to 5-0FPS a lot. I play on the lowest settings and 1280 x 720 resolution to reduce even more FPS lag.

My specs are:

Intel core I7-9750h
RTX 2070 max Q - 8GB
16GB DDR4

I've tried overclocking, running the fans at max speed, resetting the pc, scanned for faulty hardware all with no result. (I play with the laptop plugged in)

Maybe someone can help or tell me what is wrong?
Many thanks,
-Jannick

I have the same problem and tried all things that i know it could work, but nothing worked
 
Dec 11, 2020
3
0
20
0
Hi,

Have you updated your GPU drivers?

If you was previously getting higher frame rates and you have not made any significant changes to your system, id say something is running in the background which is eating up the resources needed to run the game.

Also id double check your laptop has not auto changed to the iGPU (intel HD) instead of the dedicated one (2070). You can do this via your driver settings.

Thanks
Hello,
Thank you for your response.
I have updated my gpu drivers. I often do. I double checked my driver settings too. It's still running on the 2070. At the moment I'm resetting my pc again. I doubt it will do much but i can always try.

And yes, the frames I'm used to getting are no where near to what im getting right now. So maybe I have caught a virus? I tried virus scans but to no result. At this point im clueless.
 
Dec 11, 2020
3
0
20
0
Okay so I have an update on this matter.

My GPU core clock speed was stuck on 300MHz. While my RTX 2070's default clock speed is about 885MHz. I've ran NVIDIA inspector to check this. To fix it, I completely uninstalled all graphic drivers with DDU and reinstalled the latest driver available. It is no longer sitting on idle and im getting massive performance boosts.

Comparison:
Cod Cold War ran on about 20 FPS lowest settings.
Now, I'm getting a constant 170-190fps

I hope this will fix it for the people with the same problems.
 

Deciplox

Great
Dec 8, 2020
57
1
85
0
Okay so I have an update on this matter.

My GPU core clock speed was stuck on 300MHz. While my RTX 2070's default clock speed is about 885MHz. I've ran NVIDIA inspector to check this. To fix it, I completely uninstalled all graphic drivers with DDU and reinstalled the latest driver available. It is no longer sitting on idle and im getting massive performance boosts.

Comparison:
Cod Cold War ran on about 20 FPS lowest settings.
Now, I'm getting a constant 170-190fps

I hope this will fix it for the people with the same problems.
glad you have fixed this, pleasure to of helped.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 2
Ksomoso Laptop Tech Support 1
jonbremont Laptop Tech Support 6
esmail Laptop Tech Support 1
C Laptop Tech Support 2
I Laptop Tech Support 7
N Laptop Tech Support 9
M Laptop Tech Support 6
P Laptop Tech Support 1
V Laptop Tech Support 4
S Laptop Tech Support 1
W Laptop Tech Support 3
C Laptop Tech Support 3
S Laptop Tech Support 2
H Laptop Tech Support 2
S Laptop Tech Support 2
G Laptop Tech Support 2
P Laptop Tech Support 1
H Laptop Tech Support 11
Z Laptop Tech Support 1

ASK THE COMMUNITY