Question Stuttering /Low FPS on ROG Zephyrus GA502DU

Feb 8, 2020
1
0
10
0
I bought my laptop about 2 weeks ago, I recently bought Yakuza 0 for it and the first few days it ran smoothly and was able to play a 2-3 hour session with no issues. Then a few days a ago I began to experience stuttering while roaming/fighting and then eventually during cutscenes as well. I have Nvidia Geforce GTX 1660 Ti Max-Q for reference. I've already attempted to rectify the issue by speaking to an ASUS associate through a chat, terrible. Previous attempts at troubleshooting the issue include: updating drivers, closing all background applications, Nvidia control panel>Manage 3D settings>High-perfomance Nvidia processor, BIOS reset, installed DDU. I also have noticed that even after assigning the game to use the Nvidia card, it won't use the GPU, no activity in the task manager. I have to keep restarting my computer and sometimes it fixes it but it is happening consistently. When plugged in I get a great frame rate but consistent stuttering, when unplugged I can get around 15 to 30 FPS rendering the game unplayable, I'm not really sure what options are left, I'm a novice as it relate to computers so I don't really have any direction on fixing this issue.
 
Thread starter Similar threads Forum Replies Date
IsaacSmith423 Laptop Tech Support 7
G Laptop Tech Support 1
P Laptop Tech Support 6
B Laptop Tech Support 4
C Laptop Tech Support 1
N Laptop Tech Support 6
I Laptop Tech Support 1
A Laptop Tech Support 6
B Laptop Tech Support 1
C Laptop Tech Support 1
I Laptop Tech Support 4
N Laptop Tech Support 7
K Laptop Tech Support 7
K Laptop Tech Support 2
M Laptop Tech Support 19
S Laptop Tech Support 5
N Laptop Tech Support 4
K Laptop Tech Support 3
A Laptop Tech Support 2
M Laptop Tech Support 3

ASK THE COMMUNITY