Gamecom 780 - Reversed Headphone Problem

HVG Steven

Honorable
Sep 25, 2013
2
0
10,510
0
When I do a test through my computer's sound options everything sounds fine and in order with my 7.1 headset, but when I'm in games the headphones get reversed. Grenades or footsteps SOUND like they are coming from my left but really they are to my right in the games I play. This happens even when I'm not using 7.1 surround.

I have no idea why this is happening! I have tried installing fresh drivers and using different USB ports to no avail. I also tried googling up a solution but it doesn't seem like a common problem to have.

Any help would be greatly appreciated since I need everything in working order since I am a streamer on twitch.tv! Please and thank you.
 

HVG Steven

Honorable
Sep 25, 2013
2
0
10,510
0


I already had those drivers, but I reinstalled them anyway. It didn't work, of course.
So I think I'm just gonna return them! They are a wonderful headset but it's damn annoying having to hear people come from my right in my left ear phone. I'm gonna get the G35s.

 

eggeman

Estimable
Feb 13, 2014
1
0
4,510
0
I am pretty sure I have fixed mine. I sure hope someone else can benefit from this post.

I like many others are having this same problem where my headset's sound is being reversed. Even after quitting the game, I check the settings with windows or my ( Logitech G35 7.1 virtual surround sound )program and the channels are still switched.

It seemed to be only happening with USB headsets (no matter what brand) when pluggin them into what seems to be motherboards with an AMD Chipset so I took my motherboards chipset/usb out of the equation.

I bought a Vantec 4-port SuperSpeed USB PCI Express card. Downloaded/installed the latest drivers for it and then plugged my headset into it.

It sucks to have to spend $30 to fix this issue, but I havent had a problem since (3 days worth of gaming and no issues).
 

ushito

Estimable
Apr 20, 2014
1
0
4,510
0
I found the solution, change your headphone configuration in control panel and set it to 7.1, I had it on 5.1 and it was reversed. Hope I helped.
Best of luck, ushi
 

ASK THE COMMUNITY

TRENDING THREADS