Gaming is lagging even with high fps and low ping (dota 2 and csgo)

aizuddin

Prominent
Mar 10, 2017
1
0
510
0
Hello..I just bought Lenovo Legion Y520 yesterday. After that I download Dota 2 and try play it but its lagging or more suitable word its freeze each 20 second(estimated). Then I try play csgo and the same problem is happening. I try to change some setting like high performance power and disable the Xbox dvr. But the problem is not solved.

Here is my laptop specs:
I5-7300HQ 2.5ghz
Nvidia Gforce gtx 1050 2gb ddr5
4gb of ram 2400mhz
Windows 10 home
1TB hdd (no ssd)

Can anyone please help me to solve the lagging problem. For the record, I'm beginner in this kind of situation.
 

Jerrar

Prominent
Apr 7, 2017
5
0
520
1
It sounds like a problem with the newer silicone. Since you are on Windows 10 you should try going on "game mode" this should solve your problem.
If not then go to system bios and disable the CPU Spread Spectrum () and disable Intel Speed Step Technology. Also set your CPU multiplier to stock value.
If it still does not work then install HW monitor and put the screenshot of results here for better solutions.
 

vsrajpal

Prominent
Mar 29, 2017
3
0
510
0
The problem would probably have to be your ram (Your general 4 gbs of ram). Try upgrading it to 16, because that is usually the standard for gaming. A similar problem occurs to me with Just Cause 3.
 

Ali_218

Prominent
Mar 31, 2017
1
0
510
0
Listen looking at ur specs you can play dota 2 on 120FPS 4 gb of ram is more than enough ...
Possible Solution : is your steam files, You need to reinstall steam so backup dota 2 and re-download steam
on your device "This happened to me when i copied steam files from my old laptop to my pc without installing steam"
 

Jerrar

Prominent
Apr 7, 2017
5
0
520
1
It sounds like a problem with the newer silicone. Since you are on Windows 10 you should try going on "game mode" this should solve your problem.
If not then go to system bios and disable the CPU Spread Spectrum () and disable Intel Speed Step Technology. Also set your CPU multiplier to stock value.
If it still does not work then install HW monitor and put the screenshot of results here for better solutions.
 

H_Frank

Prominent
May 2, 2017
4
0
520
2
I5 kabylake processor and gtx 1050 should be a good combination, however 4gb of ram sounds a little small, mabye try adding an extra 4gb as has been suggested. Something which may help if you have an m.2 drive is adding an m.2 nvme ssd. Also check all your graphics drivers are updated. Hope this helps :D
 
Thread starter Similar threads Forum Replies Date
theBigBig Mobile Gaming 0
E Mobile Gaming 0
M Mobile Gaming 0
A Mobile Gaming 1
P Mobile Gaming 1
Stephsniz Mobile Gaming 5
L Mobile Gaming 1
P Mobile Gaming 1
P Mobile Gaming 3
L Mobile Gaming 1
P Mobile Gaming 1
S Mobile Gaming 5
S Mobile Gaming 1
P Mobile Gaming 23
A Mobile Gaming 7
B Mobile Gaming 3
A Mobile Gaming 3
S Mobile Gaming 2
S Mobile Gaming 3
S Mobile Gaming 3

ASK THE COMMUNITY

TRENDING THREADS