GTX 850m not detected for Starcraft. Nvidia inspector solution doesn't work anymore

Titahn

Estimable
Jul 4, 2015
2
0
4,510
0
Hello everybody,

I'm in a bit of trouble. I bought a laptop powerfull enough to play Starcraft II, Diablo III, skyrim, and stuff like that :
- Intel Core i5-4200H
- GTX 850M
- 4Go of Ram
- Windows 7 (instead of the original 8.1)

However, starcraft was very laggy (like 2 fps after 10 minutes of a 1v1 game, so completely unplayable).
After searching a solution, I seemingly found one here : http://eu.battle.net/d3/en/forum/topic/10746494566

I had to used Nvidia Inspector to enable "SHIM_RENDERING_MODE_ENABLE"
in the "Enable application for optimus" category. Not a clue of what it means, but it worked !
The Video Card temperature went from 47 to 68°C in game, so my guess is that it was the integrated video card that was used, instead of the GTX 850M.

But after a few times, it didn't work anymore, again, not a clue why.

So does any of you have any idea of what I could do to make Starcraft use the GTX ? The problem doesn't occur with every game, since for Skyrim, everything is fine.

Thanks a lot for your help !
 

potattus

Estimable
Jul 4, 2015
1
0
4,520
1
I've had this problem with a few games. What you want to do is open your start menu and search for nvidia and click "Nvidia Control Panel". You want to click "Manage 3D Settings" on the left side. There will be a drop down menu you want to click on and find starcraft's file name and if it isn't there, you want to click add and direct it to the games executable file, if its a steam game it will be under the steam program files. But anyway once you have the game selected, click the 2nd drop down menu right under it and click "High performance nvidia processor" or something of the sort. Hope I helped. (and dont forget to click apply)
 

potattus

Estimable
Jul 4, 2015
1
0
4,520
1
I've had this problem with a few games. What you want to do is open your start menu and search for nvidia and click "Nvidia Control Panel". You want to click "Manage 3D Settings" on the left side. There will be a drop down menu you want to click on and find starcraft's file name and if it isn't there, you want to click add and direct it to the games executable file, if its a steam game it will be under the steam program files. But anyway once you have the game selected, click the 2nd drop down menu right under it and click "High performance nvidia processor" or something of the sort. Hope I helped. (and dont forget to click apply)
 

Titahn

Estimable
Jul 4, 2015
2
0
4,510
0
@potattus :

It was already "High performance nvidia processor" or something of the sort that was selected, so unfortunately, it didn't change anything :s
 
Thread starter Similar threads Forum Replies Date
tweeds Laptop Tech Support 3
lucasblack29 Laptop Tech Support 1
R Laptop Tech Support 8
A Laptop Tech Support 0
Secritek Laptop Tech Support 3
aztrovoi Laptop Tech Support 6
Maxwell902 Laptop Tech Support 1
R Laptop Tech Support 1
S Laptop Tech Support 3
baakudai Laptop Tech Support 5
I Laptop Tech Support 0
Atharva1313 Laptop Tech Support 0
A Laptop Tech Support 1
Kingpizza Laptop Tech Support 5
W Laptop Tech Support 1
T Laptop Tech Support 2
T Laptop Tech Support 5
newbie_techie Laptop Tech Support 6
N Laptop Tech Support 3
C Laptop Tech Support 17

ASK THE COMMUNITY