How to separate speakers from headphones

Status
Not open for further replies.

mcmarto

Honorable
Sep 11, 2013
10
0
10,560
0
Hello.
My headphones and speakers show up as one device labeled "Speakers" in the Windows "Playback Devices" window. Is there any way to set them up to show up separately?
I've plugged speakers in the rear jack and headphones in the front and they both play sound. I can't disable only one of them, as they show up as one device.

I use Windows 7, Realtec HD and desktop pc.
 

photonboy

Distinguished
It is the onboard sound solution that shows up in Playback devices not your headphones or speakers. Both the headphones and speakers use the same solution.

You can set the Realtek software to disable the sound to the speakers when you plug in your headphones, or just disable auto-detection and turn your speakers off manually then plug in your headphones.
 

mcmarto

Honorable
Sep 11, 2013
10
0
10,560
0


Yes, I'm trying to set it to disable the sound from the speakers when I plug headphones, but I can't figure out how to do it.
I turned on the option "Mute the rear output device when a front headphone is plugged in" - there's no difference. They both play at the same time.
 

photonboy

Distinguished


Then there is some glitch with your software. You could try getting the latest software direct from the Realtek site. http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false#High%20Definition%20Audio%20Codecs

Delete the orignal, reboot and install these.

If you can't get it to switch using the Realtek software then I don't know what the issue as it sounds like you did it correctly.

If that all fails, then simply turn your speakers off. I recommend you do that anyway when not needed.
 

mcmarto

Honorable
Sep 11, 2013
10
0
10,560
0


I deleted the old driver and installed the new one from Realtec's website. Problem still stays.
 

bebop460

Distinguished
Jun 25, 2011
3
0
18,510
0
I had the same issue. I solved it by clicking "make front and rear output devices playback two audio streams simultaneously" in the Realtek Audio Manager.

After that "Realtek HD Audio Second Output" appeared in playback devices. I set this second output as the default device and disabled the speakers.

Makes sense because this separates the front and back audio ports, letting you disable motherboard audio and set the front port (the "second output") as the default. Hope that helps someone.

EDIT: This actually does not stop playback from the speakers, though it makes them a lot quieter. My headphones also only play on one side with this, but it's possible that this issue is headphone related for me (they are old and cheap quality).

It's worth tinkering with anyway.
 

yoyoyoyooo

Honorable
Jan 24, 2014
1
0
10,510
0
Figured it out, in the realtek audio manager click on the folder looking thing in the top right. Check the box that says enable audio pop up dialog...... Now unplug your head phones and plug them back in. This time click on headphones instead of line out. Should be fixed. Hope that helped.
 

Beau of Blades

Estimable
Nov 9, 2014
1
0
4,510
0


some dont even have the "make front and rear output devices playback two audio streams simultaneously" in the audio manager, like me,,, updating or reinstalling doesnt fix it either
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
W Audio 1
R Audio 2
C Audio 2
E Audio 2
J Audio 1
A Audio 1
T Audio 2
R Audio 1
A Audio 1
M Audio 1
skyline4727 Audio 3
D Audio 2
D Audio 1
Z Audio 1
C Audio 1
conticreative Audio 4
J Audio 1
S Audio 2
Kriicz Audio 9
1 Audio 1

ASK THE COMMUNITY