HP Laptop screen shows weird random colors and no content and get fixed by moving the screen lid back and forth many times

Aman Kapoor

Estimable
Jul 1, 2015
1
0
4,510
0
I have this laptop HP ENVY TS 15 Notebook PC with BIOS:F.65-11/20/2014.

It's screen shows the following problems and to make it work again I have to adjust the lid back and forth several times. Recently it took me 10 minutes of lid correction to get it correct.

Here are the images -

http://postimg.org/image/681qtc0pj/
http://postimg.org/image/eetqkwqs7/
http://postimg.org/image/gko1feu8n/
http://postimg.org/image/4mr2f9fvb/
http://postimg.org/image/7je3fjlp3/
http://postimg.org/image/6ftz3l11z/
http://postimg.org/image/6pww96qaf/

And here is the video link -
https://drive.google.com/open?id=0BymANDKV-8hfTVVIclZmX285cWc

Kindly look into the matter and let me know what is this and what can be done about this.

PS. I bought this laptop in December 2013 and I handle it with utmost care since it is a gift from parents for better studies.
 

Malygris1

Estimable
Jul 1, 2015
11
0
4,590
8
It sounds a lot like there is a loose connection, probably the small ribbon cable running from the display to the system board. When you move the lid/display as you do, sometimes you are getting a connection, but I would expect it to be very undependable. Either that or something is applying pressure to the cable or connection with a similar result.

If you feel up to it, you could try using the Service and Maintenance guide for that series of notebooks, and check the connections. The other alternative would be service, whichever works better for you.

Here is a link to that guide, if you choose self service: http://h10032.www1.hp.com/ctg/Manual/c04498499
If you have warranty coverage remaining, you should contact HP directly, and check on your options.

I post on behalf of HP.
 
Thread starter Similar threads Forum Replies Date
N Laptop Tech Support 2
C Laptop Tech Support 1
T Laptop Tech Support 4
S Laptop Tech Support 4
B Laptop Tech Support 1
T Laptop Tech Support 1
B Laptop Tech Support 4
G Laptop Tech Support 5
D Laptop Tech Support 10
N Laptop Tech Support 6
A Laptop Tech Support 2
K Laptop Tech Support 1
N Laptop Tech Support 1
W Laptop Tech Support 3
O Laptop Tech Support 3
N Laptop Tech Support 1
F Laptop Tech Support 1
A Laptop Tech Support 1
M Laptop Tech Support 1
I Laptop Tech Support 3
Similar threads
Question Connection to laptop monitor got cut off, everything should be working. But hmdl shows black screen.
Question Windows 10 not starting up shows black screen on my connex laptop slim book 2. Only power light is on
Question Laptop boots to black screen but mouse shows
Question Laptop screen shows life for a few seconds randomly
Question My Dell Laptop is not switching on .Keyboard lights are on but the screen is not showing .
My Acer laptop screen is broken so I normally use HDMI but it just shows a black screen
Solved! Laptop fell down...I think it is working properly... Just that the screen is showing black and white... Can I fix this?
Solved! lenovo laptop turns on but only shows black screen
Solved! My lenovo y520 15ikbn shows black screen when i start my laptop
Solved! My asus laptop does not show anything on screen. It is blue please help
Solved! How can I connect my Hp 620 laptop which screen is broken and display is showing nothing to a TV using HDMI cable
laptop not work and not showing further screen
Solved! Cant boot ASUS k55a laptop shows black screen
Lenovo laptop boots but shows black screen after Lenovo logo
Solved! My Asus Laptop Only Shows A Black Screen
Solved! I use acer swift 3 window 10. I tried to turn on the laptop, the screen showed the acer logo but suddenly the it turned black.
I have a windows 10 acer touch screen laptop, nothiing happens after i turn it on and the logo shows up, just a black screen b
my Lenovo g450 laptop is starting up but screen is not showing
Acer aspire laptop customer not showing on screen and can't open icons
My asus x441ua laptop is showing blank screen but led is turned on after pressing the power button. I tried to Hard reboot(pre

ASK THE COMMUNITY