Question Huawei matebook d15 not fast charging

Status
Not open for further replies.
Aug 15, 2022
1
0
10
Hey guys and gals.



I have a:

Matebook D 15
4500 U
8GB/1TB



Today the OEM charger seems to not want to work with the laptop.



The charger itself appears to work on other phones/laptops just not the one it's made for.



Unfortunately I don't have another fast charging charger to try on my Huawei but the OEM one does not appear to work at all, however mobile phone ones do (but obviously a lot slower). So it seems like the laptop can charge (just slowly) but fast charging does not appear to work.



Do I buy another charger? Or if if fast charging is not working is the battery bust and it's a pointless endeavour?



If I should buy another charger can someone give me advice. I'm based in the UK but can't seem to buy an OEM replacement and (apologies) but charger outputs are all very confusing to me so I'm a bit lost but I can't seem to find one on Amazon that matches up.


The charger reads:



Input 100-240v 50/60hz, 1.8a
Output: 5v 2a 10w or 9v 2a 18w
Or 12v 2a 24w or 15v 3a 45 w
Or 20v 3.25a 65w


Is this just standard and any 65w should work?


Also I've been pushed constantly the new Windows and declined it. Could this solve the issue or does that not effect charging?


Thanks for the help guys. Much appreciated :)

Apologies in addition I have tried different cables and different sockets on the original charger
 
Nov 1, 2022
1
0
10
D15 - AMD Ryzen 7 3700u - 8gb - 512 SSD

Ive got a similar problem the power connected - not charging happening on multiple 65w chargers
Connect a low power charger and it charges slowly. But sometimes - 65w charger will do the job.

Nothing wrong with the chargers on other devices.

Ive tried everything with power resetting (including removing the battery)

My opinion is its Smart Charging in Huawei PC Manager not doing what it should be doing (in conjunction with the BIOS)
Unfortunately no way to downgrade the BIOS - currently on v1.18 but would like to be able to roll back to 1.16 to test. :(

The problem started on Windows 10 after BIOS 1.18 - have upgraded to Windows 11 and still the same problem.

I really hope theres an easy fix for this - - I really like this laptop - performs great IMHO.
 
Status
Not open for further replies.

TRENDING THREADS