Question I can't mount a 128GB Micro SD card to my tablet

Jan 11, 2020
1
0
10
0
I am using a Lenovo Tab 4 10 + (TB-X704V, Android 7.1.1, System versionTBX704V_S000038_171219_ROW).

I currently have a 64GB Samsung Evo+ Micro SD card being used as internal storage (i.e. not portable) to supplement the tablet's 16GB stock storage. When I connect the tablet to a PC, the PC recognized the card (listed as Samsung SD Card) and I am able to transfer files back and forth through MTP. The card is also visible as internal storage via Settings>Storage and in my Astro File Manager application.

I recently purchased a 128GB SanDisk Ultra SD Card to replace the 64GB one.

When I insert the new card, I get the prompt to set it up. I format as internal storage and allow the process to complet. The card is then recognized by the tablet (SanDisk is visible in Settings>Storage). However, applications such as Astro File Manager, MX Player Pro, and Gallery Vault do not see it, and when I connect the tablet to the PC, it is not visible. If I set the card up as portable storage via the tablet, the card becomes visible to the PC Astro File Manager, but not MX Player Pro or Gallery Vault.

I have tried formatting the card to FAT32 using AOMEI but this has made no difference. I have also tried with a 128GB Samsung EVO+ Micro SD card but I have the same issues.

While the official specs state that the tablet can accomodate up to 128GB in expandable storage, I am unable to make it work.

Any help would be greatly appreciated.
 

hang-the-9

Titan
Moderator
Seems the issue may not be the fact that the tablet does not see it but the applications don't work with it. You can see that fact because when you change how the card is formatted some of those applications start to use it.
 
Thread starter Similar threads Forum Replies Date
J Android Tablets 3
Z Android Tablets 3
T Android Tablets 1
K Android Tablets 1
N Android Tablets 1
C Android Tablets 1
L Android Tablets 1
J Android Tablets 1
B Android Tablets 1
B Android Tablets 3
A Android Tablets 2
T Android Tablets 3
N Android Tablets 1
N Android Tablets 1
T Android Tablets 1
H Android Tablets 3
L Android Tablets 1
T Android Tablets 2
A Android Tablets 2
M Android Tablets 1

ASK THE COMMUNITY