I can't play Dota 2 on my laptop. Always failed to create D3D device. i updated the latest driver/

littleneo

Estimable
Oct 12, 2014
4
0
4,510
0
I got a problem.Failed to create D3D device on launching dota 2. I have already updated latest graphics drivers. And the instruction from steam game support not working. Can someone help me? I bought the laptop for the reason of playing dota 2. Please help.
 

Wolfshadw

Splendid
Moderator
I don't know then. I've seen video of the game being played on the Intel HD4000 graphic, so I believe it's possible. I wonder, though, if your Geforce GT610m is getting in the way (though research says you should still be able to play it).

Did you try to manually set the screen resolution as seen in this video?

-Wolf sends
 

littleneo

Estimable
Oct 12, 2014
4
0
4,510
0


I have lenovo g580 Intel R core i3-3120M.
Graphic cards are Intel R HD 4000 and Nvidia Gforce 610 m
 

Wolfshadw

Splendid
Moderator
Not sure if it's a bad driver install (where did you download the drivers from?) or if you have the graphic settings set too high (can you even get to the set up page?)

Only thing I can recommend is downloading the latest graphic drivers from Lenovo, removing your currently installed drivers and then re-installing the ones downloaded from Lenovo. If you are able to get into the game's graphic settings page, turn down/off everything and see if it loads then.

-Wolf sends
 

littleneo

Estimable
Oct 12, 2014
4
0
4,510
0



Yes Bro, I updated the drivers correctly from lenovo website. But still can't launch. I can't ever get to Game graphic setting. How can I do ?
 

Wolfshadw

Splendid
Moderator
I don't know then. I've seen video of the game being played on the Intel HD4000 graphic, so I believe it's possible. I wonder, though, if your Geforce GT610m is getting in the way (though research says you should still be able to play it).

Did you try to manually set the screen resolution as seen in this video?

-Wolf sends
 

Shangkra

Estimable
Feb 25, 2015
1
0
4,510
0
Hi guys, after hours of trial and error, i think i've finally figured it out. I'm not much of a tech guy, so i can really explain it, but the fix ix quite simple. All you have to do, is open Control Panel --> Device manager --> Display adapters, and the right click on the primary intel GPU, and disable it. was an immediate fix for me. cheers =]
 

patir

Estimable
Aug 23, 2015
1
0
4,510
0


Hi Shangkra! This worked on me but when i start to play with bots it's going slow motion and it has cloud-like covering the whole map. I can't even see my hero. And also when i checked my DISPLAY on DXDIAG my approximate total memory has gone to 256MB only and others (manufacturer: n/a, chip type: n/a and DAC type: n/a). Maybe because of this that's why it's going in slow motion? Help please! TIA!
 

foresign

Estimable
Nov 27, 2015
1
0
4,510
0


Haha.. Me too brother T.T
It was so lag and I didn't intend to play if lag so much (slow motion)
 
Jan 15, 2016
1
0
4,510
0
Guys, I found a way to fix it temporarily.
What you do is:

My Computer -> Local Disk (C:) -> Program Files(x86) -> Open Steam folder -> Open appcache folder -> Erase Itens in appcache folder -> Restart Computer -> Dota 2 Properties -> Verify Integrity of Game Cache -> Open Game

But as I said it's not a permanent fix. Every time you turn off your computer, you will have to redo it.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
Nohen Laptop Tech Support 4
A Laptop Tech Support 2
K Laptop Tech Support 4
Q Laptop Tech Support 1
L Laptop Tech Support 1
K Laptop Tech Support 1
C Laptop Tech Support 1
J Laptop Tech Support 1
K Laptop Tech Support 2
J Laptop Tech Support 7
B Laptop Tech Support 1
M Laptop Tech Support 6
A Laptop Tech Support 1
K Laptop Tech Support 2
M Laptop Tech Support 14
H Laptop Tech Support 4
B Laptop Tech Support 2
B Laptop Tech Support 1
T Laptop Tech Support 1

ASK THE COMMUNITY