May 25, 2018
1
0
10
0
Hey guys
do you know how to fix this error in terraria
Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "PixelShader". ---> System.IO.FileNotFoundException: Failed to load XnaNative.dll. Please verify that you have the XNA Framework installed.
at ImportXnaNativeMethod((fnptr)* method, SByte* methodName)
at Microsoft.Xna.Framework.Content.NativeMethods.CreateDecompressionContext()
at Microsoft.Xna.Framework.Content.DecompressStream..ctor(Stream baseStream, Int32 compressedTodo, Int32 decompressedTodo)
at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(Stream input, String assetName, Int32& graphicsProfile)
--- End of inner exception stack trace ---
at Microsoft.Xna.Framework.Content.ContentReader.PrepareStream(Stream input, String assetName, Int32& graphicsProfile)
at Microsoft.Xna.Framework.Content.ContentReader.Create(ContentManager contentManager, Stream input, String assetName, Action`1 recordDisposableObject)
at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
at Terraria.Main.LoadContent()
at Microsoft.Xna.Framework.Game.Initialize()
at Terraria.Main.ClientInitialize()
at Terraria.Main.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)

this is a problem i suffered 2 years now pls fix i think i have no hope but i might get hopes from u guys.... any help will be appriciated
 

ASK THE COMMUNITY