I'm having trouble connecting my DVD player to my tv. I have red yellow white connectors. When ever I put my tv on and I press

Status
Not open for further replies.

Janine_3

Commendable
Mar 27, 2016
17
0
1,560
0
Hi,

I need help I'm having trouble with my DVD player and tv. What I'm having trouble connecting my them, and when I put the tv on then press source to AV/component then DVD player it says no signal. What am I doing wrong???? Please help!
 

Ryan_78

Estimable
Jan 17, 2016
29
0
4,610
6
Check that connections are secure. And also does your tv have multiple inputs? Switch through the inputs to make sure you are on the right one. Or try using a different cable or use different ports. Also try connecting with the DVD player on and have like a dvd inside and see which input. Also try to check if the DVD player works
 

lakimens

Honorable
Jul 20, 2013
163
0
10,660
20
MERGED QUESTION
Question from Janine_3 : "Someone help me..."



You need to set your tv to display from the DVD.
 

Janine_3

Commendable
Mar 27, 2016
17
0
1,560
0


I've played around with different ports. I made them tight as I can. I'm still not getting any signal. DVD player works. What's the best DVD player for a flat screen tv? I have a sonny. I just got it today. Just getting frustrated.

Thank you.
 

Janine_3

Commendable
Mar 27, 2016
17
0
1,560
0



I don't know what you mean?
 

galeener

Distinguished
Apr 9, 2010
52
0
18,590
3
Makes sure which connectors in back of the tv you are actually connected to some tvs have multiple connections for av as well as hdmi. For example if you hook the dvd to av1 then using the menu on the tv select av1 even though another setting on the menu says dvd you tv is not smart enought to auto select what you have hooked up. Now if you actually have a hook up in back that says dvd then hook the dvd player to that , that way when you hit dvd on the tv menu it should work.
 

Janine_3

Commendable
Mar 27, 2016
17
0
1,560
0


Does the colors have to match on the TV connections?
 

Firecox

Commendable
Mar 27, 2016
4
0
1,510
0
This sounds like the same problem i'm having with my turntable....The TV wont recognise the signal despite being set to composite/component its connected via the multi plug red and white ...got two reds for some reason...plus lots of other colours..tried them all but still no signal..very confused..Turntable is pre amped..some one said you need a splitter lead thats red and white each end and a small jack plug built into the other end.. which goes in the black connector on the tv multi plug..off to get one today ...let you know if it works...
 

Janine_3

Commendable
Mar 27, 2016
17
0
1,560
0


Thank you.i figured what was wrong with the connection.
 
The problem that Firecox has is different. Since the turntable is audio only the TV won't go to that input without a video signal. The solution is to connect a video output from another source. For example if your cable box is connected with HDMI then also connect the composite video out to the input that the TT is connected to,
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
J Streaming Video & TVs 1
M Streaming Video & TVs 6
M Streaming Video & TVs 1
0 Streaming Video & TVs 1
I Streaming Video & TVs 0
B Streaming Video & TVs 4
E Streaming Video & TVs 2
A Streaming Video & TVs 1
D Streaming Video & TVs 4
W Streaming Video & TVs 1
Dangerous Dan Streaming Video & TVs 1
H Streaming Video & TVs 1
K Streaming Video & TVs 1
A Streaming Video & TVs 3
Zero_Lancer Streaming Video & TVs 6
T Streaming Video & TVs 2
F Streaming Video & TVs 1
W Streaming Video & TVs 1
Z Streaming Video & TVs 1
A Streaming Video & TVs 1

ASK THE COMMUNITY