Intel UHD Graphics Control Panel reverting back to 60p Hz framerate unplug battery recurring

Status
Not open for further replies.
Dec 22, 2018
2
0
10
0
Hey all,

So I'm dealing with my ASUS Strix Hero II (GL504GM). It has both an Intel and an NVIDIA graphics card, but I believe we're just dealing with the Intel, which is a 630, driver version 23.20.16.5018.

When I first got the laptop, I found it was annoying how the screen constantly flashed black when I unplugged battery. Went into the graphics control panel, changed the display frame rate to 144p hz, problem solved... for a month.

Now, whenever I unplug the battery, the problem happens again. Only this time, when I plug it in and unplug again, the setting goes BACK to 60p Hz.

The only thing I've done differently lately was update some Intel things, none of which were the graphics card, and connect to a Steam link someone gave me. I had some issues with the framerate there, making it impossible to use. That's why I get the feeling it's a result of the connection to the Steam link.

I'm at a loss. How can I get the settings to stay?
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 4
vronti Laptop Tech Support 0
D Laptop Tech Support 0
baltay Laptop Tech Support 0
D Laptop Tech Support 6
Kaiavatar Laptop Tech Support 8
T Laptop Tech Support 1
K Laptop Tech Support 5
S Laptop Tech Support 5
P Laptop Tech Support 5
A Laptop Tech Support 1
A Laptop Tech Support 7
S Laptop Tech Support 2
K Laptop Tech Support 2
N Laptop Tech Support 2
A Laptop Tech Support 3
A Laptop Tech Support 2
G Laptop Tech Support 1
S Laptop Tech Support 4
F Laptop Tech Support 2

ASK THE COMMUNITY