Internet explorer when clicked, flashes and closes almost instantly. Only on non-administrative accounts

Fina1234

Honorable
Mar 3, 2012
6
0
10,510
0
Acer TravelMate P273

Windows 7 Professional 64-bit

I have an issue when opening Internet Explorer on any account that is registered under the domain and does not have administrative privileges. The accounts work fine on other devices but on this laptop, when Internet Explorer is clicked, it flashes for a split second and closes itself. On a local account it works fine, and on a admin account on the domain it also works fine. I have restored the system and the issue still persists. Does anyone out there have a fix for this ? Thank you.
 

jeremyj_83

Prominent
Aug 23, 2017
20
0
570
4
Have you tried turning off IE through "Turn Windows features on or off" inside of Programs and Features. That will uninstall it and then when you click it on again it will reinstall, or you could just download IE 11 and install again.
 

jeremyj_83

Prominent
Aug 23, 2017
20
0
570
4
Easy fix is don't use IE. Granted I understand that there situations where IE is the only choice, for example using Citrix Receiver. Since it works for the admin accounts, login with a domain admin user and then make the normal user an admin on the laptop. That way it can be run as admin and not have to worry about someone having domain admin privileges when they don't need it.
 

Fina1234

Honorable
Mar 3, 2012
6
0
10,510
0


Not using IE is just avoiding the issue, not fixing it. I have employees using the laptop with roaming profiles which gives them access to network drives so I can`t give them a local account. And certainly I will not give them any admin privileges.
 

jeremyj_83

Prominent
Aug 23, 2017
20
0
570
4
Avoiding IE if possible is the best solution. 99.9% of things can be done in the IT world with either Chrome or Firefox. Now I understand that there are situations where IE is the lowest common denominator since it is installed on every Microsoft OS dating back to Win 95. Unless what you are doing require IE and will only work on IE best solution is to not use it.
 

Fina1234

Honorable
Mar 3, 2012
6
0
10,510
0
As I`ve said before, avoiding IE is a non-solution. You're just avoiding the problem instead of fixing it. IE works perfectly fine on every other device and that is what I want on this one. I can`t use a different browser.
 

jeremyj_83

Prominent
Aug 23, 2017
20
0
570
4
Have you tried turning off IE through "Turn Windows features on or off" inside of Programs and Features. That will uninstall it and then when you click it on again it will reinstall, or you could just download IE 11 and install again.
 

Fina1234

Honorable
Mar 3, 2012
6
0
10,510
0


I tried doing that. Also reinstalling through a fresh install, I also tried restoring the whole windows image. Still nothing.
 

jeremyj_83

Prominent
Aug 23, 2017
20
0
570
4
Since it is still happening after a fresh install, my guess is there is somewhere that has a problematic group policy. I would say you can test that by removing it from the domain, rebooting, create a local user without admin rights, login to that user and see if it still happens.
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 2
M Laptop Tech Support 1
L Laptop Tech Support 1
B Laptop Tech Support 5
M Laptop Tech Support 8
Z Laptop Tech Support 2
D Laptop Tech Support 1
D Laptop Tech Support 2
J Laptop Tech Support 1
L Laptop Tech Support 11
A Laptop Tech Support 1
A Laptop Tech Support 1
K Laptop Tech Support 1
G Laptop Tech Support 4
D Laptop Tech Support 1
A Laptop Tech Support 4
C Laptop Tech Support 2
R Laptop Tech Support 5
B Laptop Tech Support 1
R Laptop Tech Support 4

ASK THE COMMUNITY