JBL Eon 315 troubleshooting?

Status
Not open for further replies.

jhunt3676

Prominent
Nov 17, 2017
2
0
510
0
I recently acquired a pair of JBL Eon 315 active speakers. Only one of the pair is working like it should. The second speaker has extremely low horn output but only when I crank its volume along with my mixer volume and stick my ear right up to it. The loop is working and sending signal to the other speaker when I chain them together. How should I go about troubleshooting it? Any help would be greatly appreciated.
 
Seems that either the tweeter itself or the crossover/protection circuit is faulty. The amp is shared so if it were bad the woofer wouldn't work. There might be some visual indication of blown components on the speaker electronic boards.
You could connect the tweeter to another amp or try a different tweeter connected to the speaker amp to figure out where the problem is.
If the speaker is under warranty JBL should fix or replace it depending on how long you have had it.
 
Seems that either the tweeter itself or the crossover/protection circuit is faulty. The amp is shared so if it were bad the woofer wouldn't work. There might be some visual indication of blown components on the speaker electronic boards.
You could connect the tweeter to another amp or try a different tweeter connected to the speaker amp to figure out where the problem is.
If the speaker is under warranty JBL should fix or replace it depending on how long you have had it.
 

jhunt3676

Prominent
Nov 17, 2017
2
0
510
0
Thanks for the reply audiophile. I pulled the front off each cabinet and hooked the speaker from the non-working unit and swapped it to the working unit and it worked just fine so I know my tweeter and woofer are both good. I just found the service manual for the 315s. I'm handy with a multimeter and soldering iron, but I've never had anything to do with speakers and their circuits. Wish me luck. Lol
 
Jul 26, 2018
1
0
10
0
I did not mean to vote it down.. \o/... I was looking for a way to reply as I'm new on this site. I am having trouble with the circuit board boost, flat, cut switch. It started cutting out then worked on the cut only, now not at all. Can you tell me where to find the service manual? This is for the EON 315. And if you know where to find parts?
Again, sorry for the neg post.
 

anort3

Distinguished
Moderator


You should start a new thread, not post in one that's a year old. ;)
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
LaMouette Audio 0
C Audio 1
Mr Guffa Audio 2
K Audio 5
D Audio 2
B Audio 1
B Audio 7
G Audio 0
S Audio 1
C Audio 9
L Audio 1
Y Audio 1
A Audio 1
A Audio 1
T Audio 2
C Audio 2
C Audio 2
M Audio 1
C Audio 8
J Audio 1

ASK THE COMMUNITY