Laggy/Stuttering in YouTube for Android

apcs13

Honorable
Oct 2, 2013
38
0
10,590
1
Hi everyone,

Not too long ago I picked up the new HTC One (M8) and so far I really enjoy the phone, however there is one annoying problem that I have with it that I don't think is necessarily the fault of the phone. When I watch YouTube videos on the YouTube app on all versions of the app and on all different types of internet (4G LTE and all WiFi hotspots I have tested have this issue), the video will sometimes lag for a short amount of time and then catch up a second later. This may not seem like a big deal, but YouTube is one of the apps I spend the most time on, since I not only upload content but also watch a lot of videos, so each time I see that stutter it catches me off guard and leaves a nagging thought in the back of my mind of annoyance. Also, the issue is not present in the video or on other devices, as if I rewind the video to the same spot the stutter happened, it will play normally, and watching videos on other devices such as my PC or iPod don't get this issue most of the time. Also, playback of videos from other sources on my M8, such as downloaded videos, video from other sites such as Twitch, and even most of the time YouTube directly from Chrome on my phone don't have this issue, which is why I believe that there is nothing wrong with my actual phone, but I want to make sure that I am correct so I can return the phone quickly if necessary for a new one.

thanks for the input!
 

SilentAssasinC3

Honorable
Nov 7, 2013
2
0
10,520
1


Have you updated the app?If not then do and if it keeps lagging then do a hard reset
 

apcs13

Honorable
Oct 2, 2013
38
0
10,590
1


I have cleared the cache, reset the defaults, and restored the app back to factory many times, but nothing has worked
 

SilentAssasinC3

Honorable
Nov 7, 2013
2
0
10,520
1


Have you updated the app?If not then do and if it keeps lagging then do a hard reset
 

shahbaz200

Honorable
Apr 20, 2012
287
0
11,260
62
If lags, go to settings of phone then developer options and select 'Disable HW Overlays' and 'Force GPU Rendering'.
Now go to Settings, then Battery and uncheck the option that says FASTBOOT.
Shut down phone completey and wait for ten secs
Now, press and hold Volume Down button, press Power to switch on the phone but don’t release the Volume Down key.
- the Bootloader Mode will load now.
Go and select option 'wipe cache partition' and 'yes' if prompts.
Reboot your device and check your youtube.
Please note first boot may take time because it has to rebuild cache.
 

apcs13

Honorable
Oct 2, 2013
38
0
10,590
1


App has been updated and restored many times in testing, and hard reset has been done a bunch too.
 

apcs13

Honorable
Oct 2, 2013
38
0
10,590
1


Thanks for that interesting guide. However, I am also having a messaging issue on my phone where every once in a while, I am unable to send text messages (they get stuck in the "Pending" stage) until I reboot my phone. What I plan to do to try to fix that before I take it back to Verizon since nothing else has worked yet, is wipe my phone and restore it back to factory default settings. do you think this will help the YouTube app as well?
 
Thread starter Similar threads Forum Replies Date
androidman994 Android Smartphones 1
Ruzz Android Smartphones 6
T Android Smartphones 1
T Android Smartphones 1
T Android Smartphones 1
P Android Smartphones 1
S Android Smartphones 1
Z Android Smartphones 1
C Android Smartphones 1
dankknightavngr Android Smartphones 3
T Android Smartphones 1
9 Android Smartphones 1
H Android Smartphones 1
A Android Smartphones 1
P Android Smartphones 1
L Android Smartphones 1
K Android Smartphones 1
H Android Smartphones 4
E Android Smartphones 1
G Android Smartphones 1

ASK THE COMMUNITY