Question Laptop can be connected to 4G pocket wifi but not home internet connection

Jul 3, 2019
1
0
10
0
Hi,
I'm experiencing a very weird situation.
A couple of days ago, my laptop PC suddenly became unable to connect to my home Wifi network (in short, HWN). I thought it was something to do with the PC, so I tried connecting it to a pocket wifi network (PWN), it connected just fine.
Then, I thought the problem was with HWN, so I tried connecting other devices to HWN (Play station 4, iPhone etc.). They connected just fine!
So the problem is between the HWN and my laptop PC. How should I approach this problem?
Thanks.

P/s: My laptop model is MSI G51 series. I'm using Windows 10 64-bit.
 
Try this....

1. Go to "Control Panel".

2. Next go to "Network and Internet" and then "Network and Sharing".

3. Now click on "Manage Wireless Networks".

4. On this screen, remove all wireless connections by "right clicking" on it and select "Remove network" from the drop down menu.

5. After doing this, close the open windows and reboot the computer.

6. Once the computer is fully reloaded, scan for the "WiFi networks".

7. Click on the available network that you want to access and select "connect".

8. It takes a moment, but then you will be asked to give a password for your WiFi connection. Type in the password and click the "connect" button.

It should now be connected.

NOTE: If this doesn't work, you may want to reset your modem/router, and then once it is fully loaded again, repeat the above steps.

If this doesn't work, test seeing if your laptop will connect via Ethernet. If so, then your WiFi card may be going. You can either look to replace it/have it replaced, or get an external (plugs in via USB) WiFi card.


Another way to try it is to...

  1. Go to "Settings".
  2. Click on "Network & Security" and then click on "WiFi".
  3. Now click "Manage known networks".
  4. Select the WiFi connection you want to remove.
  5. Click the "Forget" button.
  6. After doing this, close the open windows and reboot the computer.
  7. Once the computer is fully reloaded again go to "Settings".
  8. Click on "Network & Security" and then click on "WiFi".
  9. Now click "Manage known networks".
  10. Click "Add a new network" and enter the network name.
  11. Using the drop-down menu, select the "network security type".
  12. Check the "Connect automatically" option.
  13. Now check the "Connect even if the network is not broadcasting" option and click "Save".
Once you have completed these steps, whenever the device is within range of that particular network, it should automatically connect to it.


Also, you might want to check that both your modem/router doesn't have a limitation on how many devices can be connected at once (they do have that option in most cases) and also your ISP. Some of them limit the number of devices.
 
Thread starter Similar threads Forum Replies Date
AverageWhiteGirl Laptop Tech Support 1
anonymous30 Laptop Tech Support 1
K Laptop Tech Support 3
N Laptop Tech Support 2
S Laptop Tech Support 3
Irisviel Laptop Tech Support 2
wesleyad Laptop Tech Support 3
Redamed92 Laptop Tech Support 2
S Laptop Tech Support 1
Mike4604 Laptop Tech Support 0
I Laptop Tech Support 3
W Laptop Tech Support 0
E Laptop Tech Support 1
T Laptop Tech Support 2
wredroom.exe Laptop Tech Support 5
T Laptop Tech Support 2
C Laptop Tech Support 1
T Laptop Tech Support 1
TheWalkingDazz Laptop Tech Support 7
L Laptop Tech Support 1

ASK THE COMMUNITY