Laptop freezes on Windows

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0
I have an old Dell XPS L501x. It keeps on freezing. I fresh installed windows several times. It installs, then after reboot, it freezer randomly. It works just fine with Linux though. I have tried a different HDD, and done a RAM test.

By "freeze" I mean the screen freezes, the laptop becomes unresponsive, and the exhaust fans work on full speed.

I have tried both Windows 10 and 7.

It would also freeze if I plug when windows installs and then unplug and plug it in again.

Any help would much appreciated.
Abhi
 
It should allow you to change the resolution right on the desktop. When you right click on the desktop do you see an option for "Graphics Properties" or "Nvdia Control Panel"? You should be able to make it permanently change the resolution in there.

On the left you should see "Display". Click the "plus sign" next to it and then click on "Change Resolution". Click on "Resolution" in the right side window and choose the one you want to use. You can also click "Customize" to make any changes in there.

 
Due to the fact that Linux works fine, it may be a Windows driver that is causing the problem.I would suggest trying to run in "Safe Mode" and see if the problem still occurs. If not, you may need to go through all your drivers and update them to make sure they are functioning correctly. You may want to also check the memory to make sure it isn't failing.

To enter "Safe Mode":

1. Go to "PC Settings".
2. Click "Update & recovery".
3. Next click "Recovery", and then under "Advanced startup", click "Restart Now".
4. Once the "Choose an Option" screen opens, click "Troubleshoot".
5. Now click "Advanced Options", and then "Start-up Settings".
6. Then click "Restart".
7. The computer will restart, and load the "Startup Settings" screen.
8. Here you will make your "Safe Mode" option choice. Your choices are:

a. Press the "F4" key to Enable "Safe Mode".
(The computer will then start in "Safe Mode" with a minimal set of drivers and services.)

b. Press the "F5" key to Enable "Safe Mode" with Networking.
( Once "Safe Mode" with Networking starts, Windows is in Safe Mode, with additional network and services for accessing the Internet and other computers on your network.)

c. Press the "F6" key to Enable "Safe Mode" with Command Prompt.
(In "Safe Mode" with "Command Prompt" starts Windows in Safe Mode, with a Command Prompt window instead of the Windows interface. This option is mostly only used by IT professionals.)

9. Now sign in to the computer with your account name and password. (If you have one set.)
10. When you are finished troubleshooting, you can exit "Safe Mode" restarting your computer.
 

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0


Thanks for the help, but it didn't work. I did notice something peculiar however.

The laptop froze when I updated the display adapters. Also, when I hadn't updated them, there was an exclamation mark on it.

Should I disable it?

For now I am running Ubuntu on a separate drive. And yes I have tried Windows on both the drives.
 

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0


Well, no. I went to Manage devices and the Display Adapter had an exclamation point next to it. I right clicked and choose update drivers. I worked on it downloading installing. The screen went black then the proper resolution for the screen came, but then it froze.

I think I might just have to work with the crappy screen resolution.

Thanks!

Abhi

 

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0

It's not the temp. I live in Norway, I opened the window in the winter. It was freezing. Still froze(I trested that last January)

But I do think it's the display adapters
 

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0



k, i'll check it. Also an update, disabling the display adapter wanst much good either, this time when the pc tried to get the correct resolution. Instead of it getting the corrct resolution then freezing. The screen went black and the pc frooze!
 

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0


Well, I have wiped the drive a billion times (hyperbole) and done fresh installs, so I dont think so. Here are the only things left I can think of:

I freezes when the PC tries to go to the native (is that the correct term) resolution for the screen. When running Linux, it gets really close to native resolution, but Linux doesn't support that high resolutions. So I think there's something wrong with either the wiring or the screen itself. This is likely because the shell and the hinge are not exactly in mint condition. On on side the hinge is broken.

So, could you tell me a way of lowering the resolution and making it stop trying to go back to native resolution.

Regards,
Your "Pen Pal" Abhi

 
It should allow you to change the resolution right on the desktop. When you right click on the desktop do you see an option for "Graphics Properties" or "Nvdia Control Panel"? You should be able to make it permanently change the resolution in there.

On the left you should see "Display". Click the "plus sign" next to it and then click on "Change Resolution". Click on "Resolution" in the right side window and choose the one you want to use. You can also click "Customize" to make any changes in there.

 

abhyupandey21212

Commendable
Jul 23, 2016
8
0
1,510
0
Jj


I'll see if it works!

Your pen pal
Abhi
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 1
S Laptop Tech Support 9
P Laptop Tech Support 1
C Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 9
R Laptop Tech Support 3
N Laptop Tech Support 2
D Laptop Tech Support 1
I Laptop Tech Support 4
N Laptop Tech Support 19
J Laptop Tech Support 3
D Laptop Tech Support 3
D Laptop Tech Support 4
neoxblu Laptop Tech Support 8
X Laptop Tech Support 5
iXorizon Laptop Tech Support 4
N Laptop Tech Support 1
C Laptop Tech Support 9

ASK THE COMMUNITY