Laptop Graphics Driver Problem

trayfist87

Prominent
Mar 5, 2017
3
0
510
0
I have a 4 year old HP Pavillion laptop with intel 3000 hd graphics and AMD 7470m with 1GB GDDR5 VRAM running windows 10 64 bit.

The problem started when about a week ago, I downloaded the latest drivers for the GPU, I downloaded the beta ones what happened next that the laptop started to freeze, after a bit of tinkering it started to work again. Then next day I switched the laptop on and then right after the startup the login screen flashed and then there was the Black Screen.

I had understood this was because of the graphics drivers. I then went to safe mode opened device manager and than noticed something rather odd, in the monitors tab it was showing GENERIC PNP MONITOR with a yellow triangle. I uninstalled the 7470m drivers from device manager and the laptop re-booted fine.

I tried than to download the 15.7.1 drivers because they weren't in BETA. Mid installation the screen started to flicker, which was normal but after that the screen went completely black, I waited a minute, 5, 10, 30 and the screen was black, I re-booted and again after the startup the login screen flashed and than Black screen. Went to safe mode, I uninstalled them again, and the obviously there was the generic pnp monitor error.

Re-booted the computer and went to device manager, the laptop re-installed the AMD driver with no issues however an older version, I didn't want to install any new driver now. But the thing is the laptop was not using the AMD Driver, I went to battery settings and selected high performance, little did I know, I re-booted, same black screen, went to safe mode and so on. I've tried countless ways to fix this but I couldn't. I wanted to play games at a better framerate but I can't. I need a way to fix this. My OS is Windows 10 64 Bit,
 

trayfist87

Prominent
Mar 5, 2017
3
0
510
0


Okay, so I followed what you said, downloaded the beta drivers, and then restarted.
It worked but when I went to device manager there was a yellow triangle on in the Radeon HD 7400M Series.
And the resolution is messed up, which isn't big issue. Also I can't seem the download the iGPU drivers because they dont support windows 10? When I goto the intel site for downloading the HD 3000 Drivers it's up to Windows 8 64 bit.

Edit ---> Thanks to you I nearly got this fixed, I downloaded the 15.7.1 drivers instead of the beta ones, solved the yellow triangle, all thats left is to fix the resolution and download the intel drivers.
 

Kenny_57

Prominent
Jul 11, 2017
1
0
510
0
Try to roll back the driver to the regular 2000 driver. then try updating. or try uninstalling the driver from device manager, then hit search for device automatically. It worked for me.

But now, I have Windows 7 (64 bit) and i can't get mine to work.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 1
K Laptop Tech Support 5
MART3R Laptop Tech Support 1
M Laptop Tech Support 1
B Laptop Tech Support 1
N Laptop Tech Support 1
F Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 1
F Laptop Tech Support 8
A Laptop Tech Support 3
R Laptop Tech Support 4
R Laptop Tech Support 3
M Laptop Tech Support 6
R Laptop Tech Support 5
K Laptop Tech Support 4
J Laptop Tech Support 4
A Laptop Tech Support 3
M Laptop Tech Support 1

ASK THE COMMUNITY