Question Laptop keeps saying no internet with multiple networks

Feb 11, 2020
1
0
10
0
I use my laptop on campus and at home so I use multiple different wifi networks everyday. My computer will randomly "disconnect" from the internet. It will still be connected but say "no internet". I have to disconnect and reconnect and the issue goes away for a while. I don't believe its the WiFi causing this cause it happens with multiple different networks. Surely not every network is broken. It happens multiple times a day no matter what network I'm using. I have an ASUS Vivobook. This has been going on for a couple months.
 
You can try the following, however if it is due to say location (how close you are to each WiFi - distance is a factor), other devices interfering, or other WiFis interfering, then it won't involve your device directly.

Try this....

1. Go to "Control Panel".

2. Next go to "Network and Internet" and then "Network and Sharing".

3. Now click on "Manage Wireless Networks".

4. On this screen, remove all wireless connections by "right clicking" on it and select "Remove network" from the drop down menu.

5. After doing this, close the open windows and reboot the computer.

6. Once the computer is fully reloaded, scan for the "WiFi networks".

7. Click on the available network that you want to access and select "connect".

8. It takes a moment, but then you will be asked to give a password for your WiFi connection. Type in the password and click the "connect" button.

It should now be connected.

For a Home Network...

NOTE: If this doesn't work, you may want to reset your modem/router, and then once it is fully loaded again, repeat the above steps.

If this doesn't work, test seeing if your laptop will connect via Ethernet. If so, then your WiFi card may be going. You can either look to replace it/have it replaced, or get an external (plugs in via USB) WiFi card.


Another way to try it is to...
  1. Go to "Settings".
  2. Click on "Network & Security" and then click on "WiFi".
  3. Now click "Manage known networks".
  4. Select the WiFi connection you want to remove.
  5. Click the "Forget" button.
  6. After doing this, close the open windows and reboot the computer.
  7. Once the computer is fully reloaded again go to "Settings".
  8. Click on "Network & Security" and then click on "WiFi".
  9. Now click "Manage known networks".
  10. Click "Add a new network" and enter the network name.
  11. Using the drop-down menu, select the "network security type".
  12. Check the "Connect automatically" option.
  13. Now check the "Connect even if the network is not broadcasting" option and click "Save".
Once you have completed these steps, whenever the device is within range of that particular network, it should automatically connect to it.

For a Home Network...

Also, you might want to check that both your modem/router doesn't have a limitation on how many devices can be connected at once (they do have that option in most cases) and also your ISP. Some of them limit the number of devices.
 
Thread starter Similar threads Forum Replies Date
E Laptop Tech Support 2
B Laptop Tech Support 2
H Laptop Tech Support 1
B Laptop Tech Support 3
I Laptop Tech Support 3
T Laptop Tech Support 1
L Laptop Tech Support 1
TripleDigitRide Laptop Tech Support 3
D Laptop Tech Support 1
C Laptop Tech Support 5
T Laptop Tech Support 1
F Laptop Tech Support 2
A Laptop Tech Support 1
L Laptop Tech Support 1
A Laptop Tech Support 3
A Laptop Tech Support 2
M Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 1
G Laptop Tech Support 6

ASK THE COMMUNITY