Laptop not using Dedicated GPU

Status
Not open for further replies.

ricky.youtube

Prominent
Jan 6, 2018
4
0
510
0
Hi guys! i am optimizing my PC to gaming, and i notice that my display in the second monitor is running my integrated graphics card. Is this normal? Should it be my NVIDIA graphics card?
Thanks in advance.

https://ibb.co/euoSmb (Image of what i encountered)

Laptop MSI GL62M 7RD
Windows 10 Build 16299
GeForce GTX 1050
 
As far as I know it is pretty normal for it to use the integrated for an external display. You can, as you mentioned, try connecting it a different way (different port) however I can't say it will change it.

You might also check "Display" in control panel and choose the right one (when both are connected) to see if it will allow changing the settings from in there.

I can't think of another way off hand..... anyone else have any suggestions?
 
Yes it can make a difference depending on how the manufacturer set up the GPU connections. If the following doesn't resolve it (or you have already done what is listed) then yes I would try a different connection.

Are you certain that you have the other GPU to be the default GPU the laptop is using?

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.


 

ricky.youtube

Prominent
Jan 6, 2018
4
0
510
0
I already had that done, because i was tweaking for gaming performance.
I don't consider this a problem, it's just confusing to me see the integrated graphics card on the display adapter panel, because for other user's (like in youtube videos) in the display adapter tab shows the NVIDIA GeForce card.
 

ricky.youtube

Prominent
Jan 6, 2018
4
0
510
0
I uninstalled and installed Nvidia 388.71 but when i click on my second monitor "Display adapter properties" on "Adapter Type" it stills appear "Intel(R) HD Graphics 630"

https://ibb.co/keLBxG (In this image shouldn't it be GTX 1050 instead of Intel graphics card on Processor Graphics in use?)
 
As far as I know it is pretty normal for it to use the integrated for an external display. You can, as you mentioned, try connecting it a different way (different port) however I can't say it will change it.

You might also check "Display" in control panel and choose the right one (when both are connected) to see if it will allow changing the settings from in there.

I can't think of another way off hand..... anyone else have any suggestions?
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
biins Laptop Tech Support 1
Jph5674 Laptop Tech Support 2
--juliana-- Laptop Tech Support 3
Jabeabus Laptop Tech Support 1
A Laptop Tech Support 1
B Laptop Tech Support 1
K Laptop Tech Support 3
Ghaffar.dosti Laptop Tech Support 3
S Laptop Tech Support 1
T Laptop Tech Support 2
E Laptop Tech Support 1
T Laptop Tech Support 14
P Laptop Tech Support 3
V Laptop Tech Support 5
A Laptop Tech Support 3
B Laptop Tech Support 5
Y Laptop Tech Support 3
H Laptop Tech Support 2
A Laptop Tech Support 1
B Laptop Tech Support 1

ASK THE COMMUNITY