Laptop refuses to use Nvidia Graphics

Zach_W

Commendable
May 13, 2016
1
0
1,510
0
Hello,

I recently purchased a Dell Inspiron 7000 series laptop with windows 10 (received it four days ago). The computer came with intel HD graphics and Nvidia Geforce GTX graphics. A game I'm playing is having issues with the intel graphics, so I disabled them in device manager to prompt the computer to use only Nvidia graphics. (My situation has changed slightly and some of this may no longer apply, feel free to scroll down to "EDIT2")The Nvidia graphics show up in device manager and the drivers are up to date, yet the graphics only reverted to windows basic, as if the intel graphics were the only ones I have.

When trying to access the Nvidia control panel, I receive the error: "NVIDIA Display settings are not available, You are not currently using a display attached to an INVIDIA cpu".

Another thing to note, when I view system apps and features there are four Nvidia features and they are all labeled "unavailable".

It's a bummer that I'm already having issues on a machine that's not even a week old. Any help would be appreciated.

Zach

EDIT: Another noteworthy tidbit, I just tried disabling and re-enabling the Invidia Graphics and it is showing a new message in the properties menu:
"This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)
Insufficient system resources exist to complete the API."

EDIT2: I recently got a notification telling me to restart to install some graphics related update, I did it and it seems like Nvidia is now being recognized, I can open the control panel. However, I still cannot get my computer to use the Nvidia. I tried changing the preferred graphics processor from "automatic" to the High-performance Nvidia processor and restarting, but my computer is still using the intel HD graphics.
 
Hi,

Please do try these troubleshooting steps that may help. Re-enable both graphics card as well first.
- Go to Device Manager and uninstall the Nvidia graphics card driver.
- Next is to open Programs and Features then uninstall anything related to Nvidia.
- Once completely uninstalled, download and install the latest driver.
- Here's the link: http://www.nvidia.com/Download/index.aspx
- Reboot the laptop once the driver has been installed.
- After the reboot, do set Nvidia as the default GPU by not disabling the Intel graphics card.
- Here's how: http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
 
Thread starter Similar threads Forum Replies Date
K Laptop Tech Support 3
M Laptop Tech Support 4
R Laptop Tech Support 3
A Laptop Tech Support 5
A Laptop Tech Support 1
I Laptop Tech Support 3
M Laptop Tech Support 1
W Laptop Tech Support 1
BlueWidow Laptop Tech Support 3
A Laptop Tech Support 1
B Laptop Tech Support 3
H Laptop Tech Support 5
Myronazz Laptop Tech Support 4
Kerochii64 Laptop Tech Support 1
N Laptop Tech Support 1
Q Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 5
M Laptop Tech Support 18
R Laptop Tech Support 2

ASK THE COMMUNITY