Lenovo Y430 - white screen - need help

Status
Not open for further replies.

Tophaholic

Distinguished
Jan 3, 2011
4
0
18,510
0
Hello,
I have a Lenovo Y430 laptop which had an issue with the screen going completely white when moving the lcd lid. The picture is perfect if connected to an external monitor. I opened the laptop and found that the display worked if I moved the video cable. So it seemed that the display cable had a broken wire or something.

So I went ahead and opened the wrap on the video cable (big mistake). In the process I broke a few wires. On top of that I tried to power on the laptop with the broken video cable. THe display was now white for 100% of the time.

Then I ordered a replacement video cable from Lenovo. After I installed the new cable the display is still white. The picture shouws up on an external monitor but not on the LCD. I checked that there is no loose connection at the LCD and the motherboard end. So not sure what the issue is.

At first I thought I might have messed up the LCD. But I removed the LCD and tested it on a different laptop and it works fine.

Could I have shorted something on the motherboard when I powered on the laptop with the broken video cable? But the external monitor displays the picture correctly. So not sure if it really is a motherboard issue.

Any opinions/advise on what I should check?
Thanks in advance
 

Tophaholic

Distinguished
Jan 3, 2011
4
0
18,510
0
Yeah I went through this guide. I tested it with a different LCD but the LCD still shows up as white. So it points to the motherboard being bad. But It does display the picture correctly on an external monitor. If the motherboard had been bad it would have not shown the pic on the ext monitor as well.
 

mavroxur

Distinguished
Feb 8, 2009
326
0
18,960
8



If he is getting a backlight, it's not the inverter. A bad inverter would give a black screen. If he is getting a solid white screen, he is getting a backlight, but no picture. If the LCD works on another computer, and you've replaced the LCD cable, then you could have damaged the LVDS transmitter on the motherboard.
 

Tophaholic

Distinguished
Jan 3, 2011
4
0
18,510
0
I tired with a new inverter and still the same issue. Seems like mavroxur was right. There might be something else on the mobo that might have blown up. Ohh well....will sell the LCD on ebay and use the rest of the laptop with an external monitor or connected to my HDTV as a HDPC. Thanks for all your help guys.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
V Laptop Tech Support 0
B Laptop Tech Support 1
D Laptop Tech Support 5
M Laptop Tech Support 3
A Laptop Tech Support 1
T Laptop Tech Support 1
P Laptop Tech Support 1
J Laptop Tech Support 3
M Laptop Tech Support 6
B Laptop Tech Support 2
M Laptop Tech Support 2
A Laptop Tech Support 2
E Laptop Tech Support 1
D Laptop Tech Support 1
P Laptop Tech Support 1
S Laptop Tech Support 7
S Laptop Tech Support 1
S Laptop Tech Support 1
K Laptop Tech Support 1
W Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY