Lenovo Y50 4K -Video Playback Stutters Badly

00711

Estimable
Nov 6, 2014
5
0
4,510
0
Lenovo Y50 4K -Video Playback Stutters Badly

I have a new Lenovo Y50 4K Touch w/ GTX 860m, but the video playback stutters, badly, it plays previous frames from a few frames ago but audio is smooth. It doesn't seem to do this consistently, and is not limited to a single type or size or playback quality.

It does seem to do it worse on playback of larger sized content, scaled to the screen or not, it seems to be something with how the video memory is not being cleared fast enough and I think it has to do with the NVIDIA GTX 860m or the Intel HD 4600, but both have the latest drivers by Lenovo.

**Please do not try to explain about how 4K has limits or some other silliness, I have been working in computers for 30 years and this is a hardware issue not a performance issue with 4K.

Does anyone know of issues with the GTX 860m or Intel 4600 that might be doing this?

I have seen a couple people saying the same thing but no one had much to respond with, except one said they heard a bad batch was know to have shipped but I really don't want to send this back to the black hole of Lenovo support if I can find a possible software/driver solution.

Thanks!
:)
 

Shaun Oster

Estimable
Mar 13, 2015
1
0
4,520
1
Same issue here. Excitedly buy a the best screen they offer only to be rewarded with video that would cause elliptic fits (flickering). Come on Lenovo, lets see a driver update here...

Meanwhile the solution is simple. Open Nvidia Control Panel.
Set IE, Firefox, and Chrome as integrated graphics, and apply. Restart those browsers. Not to bad.
 

00711

Estimable
Nov 6, 2014
5
0
4,510
0
I check the 860m control panel, there is only options to set 3D. I have found that disabling flash in Chrome fixes the issue (at least with YouTube) so perhaps it's some incompatibility with 4k and Adobe (but that would be huge and you think they would have been on that).

There is also nothing to really set on the HD4600, just stuff around color really.
 

jesseberger

Estimable
Dec 29, 2014
1
0
4,510
0
I have the exact same laptop and had the exact same problem. The answer posted by das_stig worked for me. Chrome was running through the integrated graphics option and not the nvidia card. I switched it and it worked immediately.
 

00711

Estimable
Nov 6, 2014
5
0
4,510
0


Can you tell me where you found that option?? I have looked everywhere and have not seen that option... and I'm getting ready to send this thing back to Lenovo if I can't resolve it, have spent $1800 on a system with simple video playback issues really sucks.
 

Shaun Oster

Estimable
Mar 13, 2015
1
0
4,520
1
Same issue here. Excitedly buy a the best screen they offer only to be rewarded with video that would cause elliptic fits (flickering). Come on Lenovo, lets see a driver update here...

Meanwhile the solution is simple. Open Nvidia Control Panel.
Set IE, Firefox, and Chrome as integrated graphics, and apply. Restart those browsers. Not to bad.
 

Kawstick

Estimable
Apr 27, 2015
1
0
4,510
0
I was having the same issue and I believe I found a fix. I tried many of the solutions for this issue that I have found across the internet and none of them had worked. Through the process, however, I found that regardless of what gpu you have selected the information is always delivered through the intel chip even if the 860 is doing the work. I found that disabling/uninstalling the Intel chip stopped the issue but this broke the nvdia control panel as well as the Intel panel.

What I did has worked so far and may depend on installing the Intel HD from Intel's site and not using Lenovo sourced drivers. After realizing the connection I re-installed the intel driver (again, get it from Intel not Lenovo). I then did a clean install on my nvidia drivers because the control panel was no longer working and then set all my apps to use 860. To my dismay this wasn't a fix. I disabled the Intel HD again to double check the connection between the stuttering and sure enough it stopped. This time though, when I turned the Intel chip on the stuttering was gone. This solutions seems to work after a restart. I'm hoping that this is a long term fix and just an issue of the cards not initializing in the right order (or something like that). I will post again if anything changes.

Short version:
Uninstall Intel HD and Nvida drivers.
Re-install both from the latest drivers from the Intel and Nvidia website. Do not use Lenovo support page.
Set your nvidia control panel and all your applications to use the 860m.
Go into device manager and disable intel HD.
Check for stutter.
Re-enable Intel HD.

I hope this wasn't just a fluke for me and this is a working solution. Please comment and let me and others know if this was of any help.
 

J Nelson

Estimable
May 12, 2015
2
0
4,510
0
I'm the guy that started this thread... I have now had my system shipped back to Lenovo 2 times and the problem still persists, so I want to know what people do in this instance?? I'm not going to except a broken computer, clearly Lenovo sucks and this machine is crap.

The problem goes away sometimes when you mess with things, but after a few more minutes or pushing the graphics card for even a few minutes brings it right back.

If others are having the same issue, clearly it is not just a "broken" video card. I have installed the OS multiple times, installed the latest drivers, etc.

**Oh ya, tech support dropped my machine and damaged the corner but they won't fix that new either, asking me if I had a picture of the machine undamaged to prove they did it. What a shitty shitty company, I will never buy from them again.
 

alanca03

Estimable
May 29, 2015
1
0
4,510
0
Check your GPU clock speeds with GPU-Z; I noticed that my y50-70 has a "reverse clock" in the Intel HD4600 GPU.

When idling in the High Performance mode, my GPU is running at 1200Mhz (.2W~ draw). Although, when I was able to put any kind of real 3D workload on the HD4600 it *slowed* down; this is opposite to what I've noticed my HD3000 and HD4000 to do.

It's important to note that the HD4600 GPU; in the y50-70 when used with an 860M; is used for menial tasks like drawing the Windows User Interace (moving/resizing windows) and *video playback*.

Your "Integrated" Intel 4600 GPU could be reverse throttling during playback, play around with your Nvidia Control panel and change your "Preferred Graphics Processor".

Also, when I run my computer on High Performance- a trick I use is to set the "Minimum Processor State" to 100%. This could help. I've never been able to figure out the reverse throttling issue. I run videos on my y50-70 (HD4600 / 860M) with no lag that I can see.
 

Sportstar583

Estimable
Jun 19, 2015
1
0
4,510
0
I know that there was a solution provided but I have a better solution. Click the battery charge icon-> click 'power options'-> Click 'change plan settings' next to the power plan you are on-> Click 'change advanced power options'-> scroll down to multimedia setting and click the '+' -> click the '+' next to 'when playing video -> and then change both settings to 'balanced'. This worked for me on both the balanced and high performance power plans.
 

Borislav Kamenov

Estimable
Aug 14, 2015
2
0
4,510
0


Its works! I tried everything, but only this works. Thank you so much.
 

Michal_9

Estimable
Dec 25, 2015
1
0
4,510
0
I have the same issue now. Have you managed to solve it?



 
Thread starter Similar threads Forum Replies Date
Ksomoso Laptop Tech Support 1
ITweeks Laptop Tech Support 5
S Laptop Tech Support 1
P Laptop Tech Support 7
V Laptop Tech Support 2
A Laptop Tech Support 1
LightningsalesUK Laptop Tech Support 3
S Laptop Tech Support 1
H Laptop Tech Support 1
J Laptop Tech Support 2
C Laptop Tech Support 2
A Laptop Tech Support 1
A Laptop Tech Support 4
Manlybunny Laptop Tech Support 2
B Laptop Tech Support 2
WoodyTX Laptop Tech Support 1
M Laptop Tech Support 2
S Laptop Tech Support 4
P Laptop Tech Support 1
X Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS