Lenovo Yoga 730 screen flashing like crazy

michaelyum

Estimable
Jan 8, 2016
3
0
4,510
0
Please help a Lenovo victim here. I have been using the laptop for a month and then the screen started flashing like crazy to the point of unusable. Right now the screen starts flickering basically within 5 mins of use. Only after this issue had surfaced then I searched the internet, only to have realised Lenovo Yoga laptops are well known to have this issue. Can somebody help me???

My observations are:
1. No screen flashing or whatsoever in boot menu, images crisp
2. Screen could start flashing even on the win 10 login screen. Even without flashing, I could also tell there is some flickering on the image
3. When I duplicate the screen to an external monitor, no flashing on external monitor while it's flashing on my laptop screen

Here are what I have done:
1. Updated the graphics adapter to the latest drivers
2. Updated the BIOS to the latest version
3. Checked that "Windows Error Reporting Services" and "Problem Reports and Solutions Control Panel Support" are disabled in msconfig (some ones on Youtube suggested turning them off)
4. Called the Lenovo technical support and the representative suggested reinstalling win 10 which I wanted to save as last resort. If the problem is prevalent, there should be some solution.
 

hang-the-9

Titan
Moderator
I suggest trying #4 since you tried video drivers and BIOS already. Factory reset is best so it loads all the drivers for you.

Only other thing you may want to try is taking it apart and re-seating the video cables, but if it's in warranty you don't really want to do that.
 

michaelyum

Estimable
Jan 8, 2016
3
0
4,510
0


thanks, I have bookmarked it. I have heard a lot of people saying Lenovo laptop have screen issues. But since my screen is not flickering in boot menu, I am assuming it's not hardware issue at the moment.
 

michaelyum

Estimable
Jan 8, 2016
3
0
4,510
0


Solved the problem by factory reset, just hoping I don't have to do this every now and then. It would be super annoying.
 
Jan 8, 2019
1
0
10
0


The problem came back after I tried this the first time. Opened it back up a second time. After looking very closely at the problem area between the fan and hinge I realized that grey tab the wire runs under is supposed to harness the wire. My wire fell so far to the side of this cradle that it was jammed under the actual fan. I think this is why my screen was getting so bad. The wire was being pinched under the cradle. To remedy this, I rolled up some electrical tape and wedged it between the display wire and the fan while pulling the wire into its cradle. This seems to be gently/safely holding the wire where it belongs. I haven't had a single flicker yet.

 
Thread starter Similar threads Forum Replies Date
Paladin54 Laptop Tech Support 4
P Laptop Tech Support 3
A Laptop Tech Support 1
Pichhi Laptop Tech Support 3
F Laptop Tech Support 0
T Laptop Tech Support 1
M Laptop Tech Support 1
C Laptop Tech Support 1
G Laptop Tech Support 5
D Laptop Tech Support 10
E Laptop Tech Support 1
D Laptop Tech Support 1
S Laptop Tech Support 0
S Laptop Tech Support 3
X Laptop Tech Support 3
S Laptop Tech Support 1
W Laptop Tech Support 0
E Laptop Tech Support 2
R Laptop Tech Support 1
M Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY