Logitech g430 gaming headset does not work

all1d0isw1n

Honorable
Dec 7, 2013
2
0
10,510
0
So I just bought a Logitech g430 gaming headset, and I tried to install it. I downloaded the software on the Logitech website, and plugged in the headset with USB dongle. However after everything updated and drivers were installed, I tried to test the sound by playing some music on YouTube. however the sound came through my laptop speakers instead of the headset. In fact no sound came from the headset on anything I tried. I even opened the software and tried to test the surround sound feature by turning it on and nothing happened. Also when I gave up and unplugged the headset and I replace it with my old ear-buds, no sound comes through at all. I have to restart the laptop to make the sound work again. I would really like someone's help in trying to solve this problem. By the way, I ordered the headset on Amazon.
 

noidea_77

Honorable
Jul 28, 2012
406
0
11,210
61
Next time please tell us the laptop make and model and you operating system. Anyway: pug in the headset, and right click on the speaker icon in the taskbar, goto playback devices and watch the bars moving next to the standard playback device. If it is not the headset, you have to change the standard device.
 

noidea_77

Honorable
Jul 28, 2012
406
0
11,210
61
Next time please tell us the laptop make and model and you operating system. Anyway: pug in the headset, and right click on the speaker icon in the taskbar, goto playback devices and watch the bars moving next to the standard playback device. If it is not the headset, you have to change the standard device.
 

Nomad89

Honorable
Jan 14, 2014
1
0
10,510
0
I have the same problem
I tried the answer provided but my computer will not let me change the standard device to hear sound

I have an ASUS K53S with windows 7

 

Dave Cannon

Estimable
Jun 20, 2014
2
0
4,510
0
i have this same problem but on a desktop, unboxed the headset, installed the software and plugged the headset in as instructed, getting no sound and windows will now not let me open the playback devices to change it.

I have a dell studio 540 quad running 64bit windows 7
wondering if maybe its a driver conflict with the soundblaster x-fi extreme audio drivers and realtek HD audio drivers already installed on my system?
 

all1d0isw1n

Honorable
Dec 7, 2013
2
0
10,510
0


Try to unplug the headset, restart the computer, and open up the playback devices. Also to make sure you download the logitech g430 software from the website. Plug in the headset, and the open window of playback devices should update for the new headset. Then just click on the headset and set as default.
 

Dave Cannon

Estimable
Jun 20, 2014
2
0
4,510
0
i have the headset working without the logitek software installed but whenever i try to install the software and run it again it just freezes up and locks me out of all my volume control options so just using the headset without the software for now, any ideas?
 

CarrotCake

Estimable
Jul 8, 2015
2
0
4,510
0


Hey man, if it's plugged in the USB port 3 it won't work, have you tried plugging it in a new USB port, that rattled me
 

captiankevman

Estimable
Aug 2, 2015
1
0
4,510
0
I hate to point out the obvious here but what difference does it make what make and model it is if they are using the usb. Com on guy let try and give some good support not just have you rebooted it
 

Crooze

Estimable
Jan 25, 2016
1
0
4,510
0
This might help some of you or others in the future. If your applications sound is still coming out of your external speakers while having your USB dongle plugged in..
1 Exit the app
2 Rich click the speaker icon on your task bar and select 'Playback devices'
3 Find the G430 entry
4 Set it as the "Default Device"

Now every time you plug in your USB dongle it because the "Default" audio device.
 
Thread starter Similar threads Forum Replies Date
Kaza503 Audio 0
twissen Audio 4
DionL Audio 1
B Audio 6
I Audio 2
chibamarco Audio 1
P Audio 2
V Audio 5
D Audio 1
P Audio 1
K Audio 3
P Audio 3
L Audio 1
W Audio 4
X Audio 1
R Audio 1
L Audio 10
F Audio 3
J Audio 1
C Audio 1

ASK THE COMMUNITY