Logitech z506 5.1 surround

NathanSwift

Estimable
Dec 26, 2015
3
0
4,510
0
I bought my Logitech z506 5.1 surround system yesterday but i can't get my rear speakers to work. I do have a rear speaker jack to my subwoofer and then on my motherboard. I got a asrock z77 extreme 4 motherboard. When i go to my realtek hd audio manager, it says there is a signal from the audio jack but there is just no sound coming from it. I already got my settings to 5.1 surround and i checked if the cables are on all right spots and it should be fine. it's not the speaker itself because i but the speakers in the other jacks and they work fine. When i go to realtek and i enable 5.1 surround i can't enable rear speakers. i can only enable side speakers. i don't know if that is the issue. but on the motherboard it says rear too. the front speakers, center speaker and sub woofer are doing great. Do i need to get a sound card or is it the software? please help me. :(
 

ssddx

Glorious
Moderator
the back of the subwoofer is color coded and your pc outputs should be as well so its hard to not get it right but i'll list just in case.

green to green : front speakers
orange to orange : center and sub
black to black : rear speakers

now, in your audio options (you could look in either your realtech audio drivers or right click the volume icon, playbaack devices, configure) there may be two options for 5.1 audio. one is often with "surround speakers" (sides) while the other is with rear speakers (rear). it sounds like you have your system set to the prior instead of the latter. this will be SL/SR instead of RL/RR if abbreviated.

always run a speaker test to see if you get tone out of them as well.

example image of surround vs rear http://files.tested.com/photos/2012/03/16/55-16018-speakerplacement_7_1.gif
correct setup showing RR and RL http://11986-presscdn-0-77.pagely.netdna-cdn.com/wp-content/uploads/2011/01/Setup-Surround-Sound-in-Windows-7.png
what it probably looks like on realtech for you http://i.stack.imgur.com/IVPSN.jpg

if rear is still greyed out double check that you have them plugged into the right jack on the back of the pc for rear! if you do, it could be that your onboard might use shared jacks - make sure that the jack is set to rear channel if you have the option to do so.
 

NathanSwift

Estimable
Dec 26, 2015
3
0
4,510
0


Well i did check and i only have one option in my motherboard and it says rear. i got the black cable in the rear and in the subwoofer. well it does look like on the photo's but the rear pair is grey like the side pair is in the picture. but the side pair is activated on my screen. that could be the problem but how do i fix this if it's not the cables. i don't have a side pair input at the back of my computer. my motherboard is like this at the back. http://www.xbitlabs.com/images/mainboards/asrock-z77-extreme6-extreme4/back2.jpg
on my version of the motherboard the silver is black and it says what the jacks are for. you can't see that here but the black one says rear.
 

ssddx

Glorious
Moderator
completely uninstall all of your audio drivers. download the newest audio ones from the official site for whatever OS you have http://www.asrock.com/mb/Intel/Z77%20Extreme4/?cat=Download
could be borked drivers for sure, i've seen stranger.

see if you have more features or are able to make the changes in realtech software then. sorry i can not guide you through it step by step but i do not use the realtech drivers on my motherboard (i use hdmi out to a home theater).

it definitely does sound like a driver issue to me but try making sure the wires are seated correctly in the plugs just to be sure.

you did not mention but please confirm here that windows test tone does not fire for rear when testing.
 

NathanSwift

Estimable
Dec 26, 2015
3
0
4,510
0
i installed newest driver version and still the same issue. and windows test tone does not fire rear. i think i am going to buy a sound card then for other software. i asked on many other forums but no one knows how to fix this.
 
Thread starter Similar threads Forum Replies Date
Wick Gaming Audio 0
simonaplatten Audio 2
T Audio 0
B Audio 5
deusman Audio 1
Q Audio 6
7 Audio 1
M Audio 3
D Audio 6
F Audio 3
J Audio 6
R Audio 1
A Audio 2
V Audio 1
M Audio 1
G Audio 2
I Audio 3
K Audio 1
J Audio 1
R Audio 1
Similar threads
Question Not getting 5.1 true surround on PS4 from Logitech Z906.
Question Logitech Z906 5.1 surround sound, only just unboxed, problems...
Question Logitech z 506 or z 906 for realistic surround sound while not caring for the bass?
Question Subwoofer on 2.1 speaker system not working(Logitech Z623) when connected via aux
Question How does one hook up 5.1 surround sound ? (Logitech Z607)
Question my led tv has no digital audio out, and i want to connect it to hd audio rush 5.1 for better surround sound of my logitech z506 speaker. please help!
Solved! Is my Logitech Z506 Surround Sound Speaker set compatible with a HP Pavilion 23 PC?
Solved! Achieving Surround Sound with additional active subwoofer
Solved! Logitech Z506, surround system from hell
No output from center/rear speakers with Sound Blaster Z
What is the difference between X-fi and x-fi hd
Which high-end real headphone, amp/dac or soundcard should i get?
Trying to set up Logitech z506 to either my TV or PS4 Pro. Wanting 5.1 Surround Sound, not Stereo.
Trying to Achieve true 5.1 surround sound with Logitech Z906 Speakers & 55" Sony xe8096
Trying to Achieve true 5.1 surround sound with Logitech Z906 Speakers & 55" Smart TV
How to connect the Logitech Z506 to the HP Envy Desktop 750-537cb for true surround sound?
Logitech Z906 Surround System, rear speakers too low.
I'm not sure which rca cables to plug into my tv from Logitech surround sound system. I have a black, tan, and green one but t
Logitech z506 5.1 surround major problem, please help!
Distortion with z906.

ASK THE COMMUNITY