Logitech Z623 Subwoofer making no sound?

Status
Not open for further replies.

beginnerbuild

Distinguished
Feb 13, 2011
5
0
18,510
0
I just got the Logitech Z623 system. I believe I have plugged in everything correctly: Right speaker and left speaker to subwoofer, then the green audio cable from computer to subwoofer. When I press the ON button on the right satellite speaker, the 2 satellite speakers emit sound but the subwoofer does not.

I've youtube'd for some bass music and cranked up the bass knob to half/full. Still no sound from subwoofer.

Did I do something wrong or is this evidence of faulty subwoofer?

NOTE: This is a refurbished system.
 

rhatch

Estimable
Jul 6, 2015
4
0
4,510
0
I had this same problem.
The solution was found with the proper setting for my Realtek Audio HD Manager that handles the sound card.

You would think that the correct way to configure it for these speakers would be to select 5.1 and then deselect the center, side and rear speakers, so that only the front left-right speakers and subwoofer remain selected. You would think that. I did. And I was wrong.

Instead, set Speaker Configuration to "Stereo", deselect "Full-range Speakers", select "Virtual Surround".
These speakers separate the subwoofer frequencies without help from the sound card, trying to select this at the sound card creates a fail. It's nice to only need one cable from the subwoofer to the computer, but a lack of instruction from Logitech creates a mistake that is easy to make.
 

OldManSpock

Estimable
Nov 29, 2015
1
0
4,510
0


I don't understand, I am having the same problem. Everything is connected fine. I checked Realitech Audio Manager and did what you said, i went to stereo. You can't deselect Full-Range Speakers, it's the part of it. In it, it says there is "Front left and right", and "surround speakers. However there is no "Virtual Sounds option. Can you please make this simpler

 

milehigh

Estimable
Jan 2, 2015
21
0
4,560
0
I know this is an old thread, but just wanted to reply in case anyone ran into the same problem. I just got the Z623 today, and after hooking it up, I was like, where's the bass?! I was ready to return the system, but then I got it working. In Win10, you need to go to control panel > sound and then click your audio output device, and click the configure button. Mine was originally on 2ch stereo, but I changed to 5.1 surround, clicked through a few screens, unchecked center and side speakers, and finally unchecked the 'full range' option. Voila!

Bass is great now, and the system sounds pretty darn good =)
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
B Audio 5
K Audio 2
Ausbeancounter Audio 3
K Audio 1
S Audio 2
B Audio 1
J Audio 6
M Audio 2
M Audio 3
S Audio 5
L Audio 1
R Audio 1
E Audio 1
J Audio 2
S Audio 1
W Audio 1
D Audio 2
J Audio 3
F Audio 5
S Audio 1

ASK THE COMMUNITY