Low performance when charger is plugged in

AlexR0

Estimable
Sep 2, 2014
2
0
4,510
0
I got this laptop: Dell Inspiron N5010 with i5 2,40GHz processor, 8GB Memory and a Kingston SSD.

4 months ago my charger`s pin jack has broken, but it was still working. I noticed that the performance had decreased drastically when the charger was plugged in, so i bought a new charger, and all was working fine.

Last week my laptop was very laggy so i decided to reinstall Windows 8. After a clean installation, the same problems occurs with the charger.

When the charger is plugged in ( even if the battery is inside or outside ) the performance if very low. When i remove the charger and start the laptop with the battery the laptop works perfect.

The power options are set to High Performance in both cases.

So what should be the problem ?

This is with the charger plugged in


This is with the battery without the charger
 

AlexR0

Estimable
Sep 2, 2014
2
0
4,510
0
After a lot of documentation over the internet i found out how to fix this after i read a thread on superuser.

I disabled the SpeedStep option from BIOS and now my laptop works fine.
 
Thread starter Similar threads Forum Replies Date
abhi2010ahm Laptop General Discussion 1
A Laptop General Discussion 5
MRPlanetfall Laptop General Discussion 2
adamv2103 Laptop General Discussion 0
E Laptop General Discussion 2
J Laptop General Discussion 0
HenZYT Laptop General Discussion 0
_Snoopy_ Laptop General Discussion 1
T Laptop General Discussion 1
T Laptop General Discussion 1
S Laptop General Discussion 1
Y Laptop General Discussion 7
S Laptop General Discussion 1
C Laptop General Discussion 2
M Laptop General Discussion 1
D Laptop General Discussion 4
S Laptop General Discussion 10
G Laptop General Discussion 5
Z Laptop General Discussion 3
5 Laptop General Discussion 1

ASK THE COMMUNITY