Minor display issues after a cleaning/thermal repasting

corporate129

Prominent
Dec 30, 2017
1
0
510
0
I just took apart my laptop and I’m having slight display issues after reassembly. The colors are just a little off (too much green or something) and everything is a little low-res. Desktop icons look like they have little lines through them.

I don’t think it’s a video card issue because everything looks fine on an external display. What else could it be? Did I not connect a cable properly? Could it be a software issue?
 

Saga Lout

Olde English
Moderator
Both ends of the screen's ribbon cable have a fairly tenuous hold on life and if one end or ther other isn't perfectly aligned in it's connection, you will get what you're seeing. Go back in and check the motherboard end and that it isn't squashed where it goes into the lid.

The screen end should be fine if you didn't remove the screen.
 

Saga Lout

Olde English
Moderator
Both ends of the screen's ribbon cable have a fairly tenuous hold on life and if one end or ther other isn't perfectly aligned in it's connection, you will get what you're seeing. Go back in and check the motherboard end and that it isn't squashed where it goes into the lid.

The screen end should be fine if you didn't remove the screen.
 
Thread starter Similar threads Forum Replies Date
wei kheng Laptop Tech Support 0
Arthurdensley Laptop Tech Support 0
jambo_hatdog5 Laptop Tech Support 0
W Laptop Tech Support 3
OhGod Laptop Tech Support 0
A Laptop Tech Support 0
ferrarachristian8 Laptop Tech Support 1
debashis_das Laptop Tech Support 2
idotmatty Laptop Tech Support 0
Satish3409 Laptop Tech Support 3
SirDeafCheese Laptop Tech Support 3
S Laptop Tech Support 2
kursat42 Laptop Tech Support 4
T Laptop Tech Support 1
T Laptop Tech Support 1
S Laptop Tech Support 13
S Laptop Tech Support 2
J Laptop Tech Support 4
T Laptop Tech Support 1
T Laptop Tech Support 2

ASK THE COMMUNITY