Multiple performance issues in with new laptop.

Uuyucool2012

Honorable
Dec 16, 2012
11
0
10,560
0
Hi,
I recently brought the brand new Lenovo y410p gaming laptop,this one has switchable Intel HD 4600 and Nvidia Geforce gt 750m graphics.

But recently I have been observing that games like Bioshock Infinite and Far Cry 3 run smoothly on high to ultra settings while GTA IV, which is a pretty old game lags even on medium settings and when I run the ingame benchmark it detects my gpu as intel hd 4600 and not gt 750m.
I have tried running the game keeping, Nvidia's as the default graphics processor(latest drivers).
I have seen many Youtube videos of people running GTA 4 on ultra on gt 650m and they run very smoothly.

Also my laptop gets very hot CPU:- 50-60 C, GPU:- 70-80 C, are these temperatures bad.

Please help me resolve my problem.
 

Uuyucool2012

Honorable
Dec 16, 2012
11
0
10,560
0


I don't know, I got the laptop as a gift from my uncle overseas, I received only the laptop and a charger.

A day before I was getting 60 fps consistent, now today it wot touch 30 fps.
 
Thread starter Similar threads Forum Replies Date
E Laptop Tech Support 1
B Laptop Tech Support 2
W Laptop Tech Support 0
P Laptop Tech Support 1
N Laptop Tech Support 1
A Laptop Tech Support 15
D Laptop Tech Support 1
vexefon Laptop Tech Support 11
E Laptop Tech Support 1
T Laptop Tech Support 2
C Laptop Tech Support 2
J Laptop Tech Support 2
S Laptop Tech Support 9
P Laptop Tech Support 5
G Laptop Tech Support 1
C Laptop Tech Support 1
M Laptop Tech Support 3
T Laptop Tech Support 1
O Laptop Tech Support 1
F Laptop Tech Support 1

ASK THE COMMUNITY