My alienware 766 screen is blank

DAS74617

Distinguished
May 27, 2010
2
0
18,510
0
i have a alienware area 51 766 recently i swtiched it on to find the fans running power to the LEDs but nothing on the screen. any idea of what the problem could be?
 

buwish

Splendid
Moderator
It's most likely a sign that the inverter has gone out. If it is still under warranty, send it in to Dell to have it repaired. If not, you can find inverters all over the net and I'm sure you'll be able to find one for your specific laptop. Take a look at the the guide on how to take apart a laptop at the top of the forum for more info on installing it.
 

DAS74617

Distinguished
May 27, 2010
2
0
18,510
0
when connecting to a external monitor i still have the same problem i get sound from the fans and the LEDs on the keyboard light up but no signal to he external screen any ideas?
 
Thread starter Similar threads Forum Replies Date
R Laptop General Discussion 0
F Laptop General Discussion 0
Starwraith Laptop General Discussion 1
C Laptop General Discussion 0
S Laptop General Discussion 2
mjmani22 Laptop General Discussion 12
P Laptop General Discussion 1
S Laptop General Discussion 5
K Laptop General Discussion 1
C Laptop General Discussion 12
B Laptop General Discussion 3
B Laptop General Discussion 1
D Laptop General Discussion 1
J Laptop General Discussion 3
A Laptop General Discussion 1
A Laptop General Discussion 2
V Laptop General Discussion 3
pappas215 Laptop General Discussion 2
H Laptop General Discussion 1
N Laptop General Discussion 2

ASK THE COMMUNITY