My lenovo yoga 8 is stuck on lenovo logo screen tried pressing power and volume buttons but the logo keeps. Coming back up & I


Jun 7, 2017
My lenovo yoga 8 won't move from lenovo logo screen tried all suggestions I can find. But don't know how to remove battery if that is an option please need help urgently!!! Thankyou
Try starting up the device in "Safe Mode" and see if it will load. Not all things will work in that mode, but if it does start up then you know there is something on the device that is preventing it from starting normally. Should that be the case, you will have to remove whatever is causing the problem before restarting out of "Safe Mode".

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
Apr 23, 2018

I had the same problem with my Lenovo Vibe P1. Does it power on and then get stuck or does it just not power on at all? And have you tried charging the phone?
What I did was I pressed down the volume keys + power button and as soon as the screen lights up, leave the power button but still hold the volume keys down. It would enter another screen whereby you'd see options like "reboot, install update package, wipe user data" and "power off". Instead of going for a factory reset, I selected "install update package" and just clicked on the yes option that follows on the next screen(it reads something like install from internal memory).
The update of course failed because I didn't have an package in my phone. Once that is done, go back to the menu and select power off. Switch it back on after a few seconds and see if that works for you :) It worked for me :D
Jun 16, 2018

This worked for me too. The Wipe cashe, factory reset wipe did NOT work, but choosing update from SD card (with no sd card in the tablet) the update of course failed but then it did reboot!!!! Awesome. Thanks.
Thread starter Similar threads Forum Replies Date
F Android Tablets 0
A Android Tablets 1
luckypigpig Android Tablets 4
A Android Tablets 0
K Android Tablets 0
I Android Tablets 2
Auster1805 Android Tablets 0
R Android Tablets 10
SaturnSolar Android Tablets 1
N Android Tablets 1
S Android Tablets 1
J Android Tablets 2
A Android Tablets 3
R Android Tablets 1
B Android Tablets 1
K Android Tablets 1
S Android Tablets 3
J Android Tablets 1
T Android Tablets 1
A Android Tablets 1