My NEW Hisense Model:50R7050E new out of box no sound no picture but LED light shows on. Properly plugged in to power. No othe

Apr 20, 2018
1
0
10
0
My NEW Hisense Model:50R7050E new out of box no sound, no picture, but LED light red showing on. Can see screen light in a dark gray/black. Properly plugged in to power. No other equipment attached or installed, no cable, just the tv.
 
With nothing else connected to the TV you can't get picture or sound but if you can't get the TV menu to appear the TV is DOA.
If you can get the menu up then connect your sources. If you use an antenna you can connect that first and run the setup so the TV can scan for available channels. After that you should get picture and sound. Then connect your other sources.
 
With nothing else connected to the TV you can't get picture or sound but if you can't get the TV menu to appear the TV is DOA.
If you can get the menu up then connect your sources. If you use an antenna you can connect that first and run the setup so the TV can scan for available channels. After that you should get picture and sound. Then connect your other sources.
 
Thread starter Similar threads Forum Replies Date
Yasseria Streaming Video & TVs 2
RexIsReckless Streaming Video & TVs 1
M Streaming Video & TVs 1
J Streaming Video & TVs 1
C Streaming Video & TVs 1
M Streaming Video & TVs 1
S Streaming Video & TVs 1
J Streaming Video & TVs 1
P Streaming Video & TVs 1
M Streaming Video & TVs 1
S Streaming Video & TVs 2
L Streaming Video & TVs 1
T Streaming Video & TVs 1
D Streaming Video & TVs 2
W Streaming Video & TVs 1
K Streaming Video & TVs 1
L Streaming Video & TVs 1
R Streaming Video & TVs 1
N Streaming Video & TVs 1
D Streaming Video & TVs 1

ASK THE COMMUNITY