My speakers don't play low frequencies... at all

SIR_MagZz

Estimable
Jan 3, 2016
5
0
4,510
0
My speakers - a pair of Rokit RP5 G3's - are brilliant. I got them today and everything sounds great... Except low frequencies. What on earth is causing this??

I believe it is my audio interface. I ordered a Focusrite Scarlett Solo (2nd Gen) and it only has 1 TRS output designed for headphones. I was disappointed that my speakers didn't both connect properly, so I purchased a Focusrite Scarlett 2i4 (2nd Gen) which has dual TRS output so my speakers will work. This arrives tomorrow. Is the issue caused by the lackluster way i'm testing out the speakers?

The attached video (https://drive.google.com/open?id=1Z6i52_jwi4TQEysIq_38t8Oprcxpneh3) shows my current testing setup. The song is 'Dark Sky' by Dropgun (https://www.youtube.com/watch?v=2Kns57XErzs). Take a listen and hear the HUGE difference between yours and my speakers.

I'm probably being incredibly dumb, but any help is appreciated :)
 

gdmaclew

Distinguished
May 20, 2008
55
0
18,610
7
Are the LF and HF adjustment set at the factory setting of 0 dB?
Is the volume set to the factory setting of +6dB?
Which input port are you using on the Scarlett? RCA or TRS?
What are you using for your source?
 

SIR_MagZz

Estimable
Jan 3, 2016
5
0
4,510
0


LF and HF set to 0 dB. Not sure about the volume, I turned it up a bit.

I'm using TRS

What do you mean source?
 

gdmaclew

Distinguished
May 20, 2008
55
0
18,610
7


Where is the audio coming from...PC, iPod, etc?

 
Thread starter Similar threads Forum Replies Date
C Audio 0
Brown66 Audio 3
S Audio 1
J Audio 1
dopeeh Audio 1
B Audio 1
S Audio 0
manoj3sharma Audio 0
A Audio 1
BreadgoatX Audio 0
V Audio 1
J Audio 8
V Audio 12
I Audio 1
H Audio 2
Nigh Audio 3
T Audio 3
G Audio 6
G Audio 119
G Audio 10

ASK THE COMMUNITY