Solved! Nakamichi Receiver 2 - B channel Speakers Don't Work

Status
Not open for further replies.
Mar 3, 2020
2
0
20
1
Hello Y'all! Been a long time follower and reader but here is my first question. Nakamichi Receiver 2 'B' speaker terminals have been cutting out lately for no apparent reason, the 'A' terminals are functioning fine. Sometimes they will come on again, sometimes if I just open the front panel control door they will go on or cut off, very odd. I can hear the relay click when switching back and forth but they just aren't working now. Tried different speakers, wires, different CD player. Opened cabinet and blew dust out, still no happiness. Can anyone lead me on what might be going on or what I can do, if so, many thanks in advance! https://s23.photobucket.com/user/littlebuddytoo/media/naki/s-l1600.jpg.html?sort=3&o=0
 
Mar 3, 2020
2
0
20
1
I found the problem, I pulled the tiny variable loudness knob off and a wire behind the face plate was making slight contact with the knob, just enough to make it angry, and I blew canned air into the variable capacitor that is attached to the knob and I guess that blew dust or something out of that rheostat. Works fine now. Thanks.
 
Mar 3, 2020
2
0
20
1
I found the problem, I pulled the tiny variable loudness knob off and a wire behind the face plate was making slight contact with the knob, just enough to make it angry, and I blew canned air into the variable capacitor that is attached to the knob and I guess that blew dust or something out of that rheostat. Works fine now. Thanks.
 
Status
Not open for further replies.

ASK THE COMMUNITY