New laptop (ASUS UX305F) - Can't setup up bluetooth support

Boooster

Honorable
Sep 13, 2013
4
0
10,510
0
Hi all,


I recently purchased an ASUS UX305F which is supposed to come built in with Bluetooth 4.0 (I'd like to attach it to a bluetooth portable speaker for music - the model I have requires Bluetooth 3.0 or higher), but after two days of frustration I'm turning here for some guidance.


The laptop came with windows 8, so I downgraded to Win 7 Ultimate edition and proceeded to install all the relevant drivers directly from manufacturer's website as ASUS doesn't provide Win 7 drivers for this model. I've managed to get everything aside from Bluetooth up and running, and I will outline what I have tried so far so hopefully someone can provide some insight as to what I'm doing wrong



In my program entries I have the following installed:

1. Wireless drivers (Intel PROSet/Wireless Software) v 18.12.1

2. Intel ® Wireless Bluetooth ® (patch version 17.1.1512.771)



I've tried using the Intel Driver Update Utility and it tells me I can upgrade the Wireless and Bluetooth drivers, but the wireless driver is updated to latest version ), and for Bluetooth it tells me to update to 18.12.1 (same version as wireless driver) but it times out when trying to download. When searching online, the version I have seems to be the latest version.



Checking in services.msi I have four entries related to Bluetooth running (BT Device Monitor, BT Media Service, BY OBEX Service, BT Support Service), but I can't see anything related to Bluetooth in Control Panel or Device Manager - when I try to add a device manually it doesn't detect anything with Bluetooth (neither phone nor speaker). If I search for Bluetooth in the start menu I have "Bluetooth File Transfer" as an option but it doesn't work (can't connect with anything).



I've tried uninstalling and re-installing wireless and BP drivers to no avail, and can't find any "Enable bluetooth button" on my laptop I may be missing.

I've tried using Fn+F2 and I get the popup showing me that I can turn off wireless and turn on Bluetooth, although in reality bluetooth remains off and wireless doesn't turn on/off based off my selections. The other Fn buttons work though, like volume, so not sure what to make of that. Is there a way to run force run bluetooth?


Unrelated (I think) I have several Yellow explanation point items listed in other devices (two unknown, two other items which I don't think are related) that I am unable to get rid off, but the computer functions fine so that is less pressing


Any help would be be much appreciated
 
Hi,

It should be the driver which is not working correctly as it should. Here's what you can try.

1. Uninstall the Bluetooth driver from Device Manager.
2. Use this link from Intel where it will scan every Intel component you have in your PC and will give you the exact driver that your laptop needs.
3. Install the driver found for your PC the reboot it once the installation is complete.
Here's the link of Intel website: https://downloadcenter.intel.com/ (Click on "Update Drivers")
 

Boooster

Honorable
Sep 13, 2013
4
0
10,510
0
Bluetooth isn't showing up in device manager - I've tried that by uninstalling from Program Entries but when running the intel driver update it tells me I need a new wireless and Bluetooth component, but it fails at the download stage for the bluetooth component. Instead, I noted the Bluetooth driver version number and found that same version manually and installed it which leads me to my present situation.

I'll give it another shot though
 

Boooster

Honorable
Sep 13, 2013
4
0
10,510
0
Nope, tried again - even tried using driver versions specifically said to be compatible by Intel (http://www.intel.com/support/wireless/wlan/sb/CS-034940.htm) and still doesn't work..
 

colbey

Distinguished
Nov 14, 2010
4
0
18,510
0
Read your post with interest (and several others here and elsewhere regarding ASUS and Bluetooth). Thought i'd let you know what I have, so you can compare. Not sure if it's useful.

I have an older ASUS: K55A-BBL4. think i got it fall 2012. it does NOT have Bluetooth; it was optional and i either wasn't aware that i could add it/it wasn't already in there, or...i didn't give any thought to Bluetooth at that time.
However, even though it came without Bluetooth, this is what my system has/shows. Note: I don't know what I did in January 2014 that there were suddenly new installs. I am hideously bad about checking for driver updates, etc., etc.

Start Menu: Intel PROSet Wireless--WiFi Advanced Statistics, WiFi Event Viewer, and WiFi Manual Diagnostics.
Control Panel: nothing about Bluetooth.
Device Manager: Atheros AR9485 Wireless Network Adapter; MS Virtual WiFi Miniport Adapter; Realtek PCIe GBE Family Controller
Programs: Intel PROSet/Wireless for Bluetooth + High Speed (installed 8-13-15), v. 15.0.0.0083
Intel PROSet/Wireless Software for Bluetooth Technology (installed 1-15-14), v. 2.1.1.053
Intel PROSet/Wireless WiFi Software (installed 1-15-14), v. 15.00.0000.0708
Realtek Ethernet Controller Driver (installed 1-15-14), v.7.48.823.2011
Services/Local: Bluetooth Device Monitor, Startup Type: Auto
Bluetooth Media Service, Startup Type: Manual
Bluetooth OBEX Service, Startup Type: Auto
Bluetooth Support Service, Startup Type: Manual
Intel Centrino Wireless Bluetooth + High Speed, Startup Type: Auto (Delayed)
Intel Centrino Wireless Bluetooth + High Speed Service, Startup Type: Auto (Delayed)

Granted, I may have, somehow, added a couple of these things the last month or so. I've been trying to get a Bluetooth connection with my ancient Nokia phone, so i can get the pics off its internal memory card (no cable, and i lost the 2GB SD card that i used with it--ones that small are not so easy to find. without ordering online, i mean). But i left off, here, any Nokia stuff that was listed, because i did install their... some sort of Suite.

But, one of the reasons I've been trying to get the phone to hook up was BECAUSE I saw Bluetooth stuff in the Programs. It was only later, when nothing seemed to work, that I checked online and found out that Bluetooth didn't come with my laptop. It just is very curious that a system they were pretty clear about NOT having Bluetooth actually has some of the same things that your system--that is SUPPOSED to have Bluetooth--does. Obviously, i don't have the newest drivers for things. (Although I need to get them because this machine needs a clean install of Windows 7 [which it is running now, btw], and i want the necessary drivers ahead of time.)

Anyway, in trying to figure this out (such a simple task, i thought--get the pictures off the phone) it seems MY options are to replace the WiFi card, or get a dongle. From other questions/posts here, it seems the first might not be an option. (Although, if it is, and/or if you want to do something similar, this site has a good guide for getting into an ASUS laptop. It likely won't be exact, but it should be similar: http://www.insidemylaptop.com/how-to-disassemble-asus-k53u-laptop/ )

And ASUS has a Bluetooth dongle: http://www.amazon.com/ASUS-USB-Adapter-Bluetooth-USB-BT400/dp/B00DJ83070
It's available on amazon for $14, although there seems to be some questions there about whether or not it works with Windows 7 (or 8).
That shouldn't be of great interest to you, because you are supposed to HAVE it already, not have to pay another $14 for it. You should probably ask ASUS support about the whole thing.

But you MIGHT find the "support" for the 4.0 Bluetooth USB adapter of interest. I downloaded the latest version of the driver earlier tonight. It only took a little over an hour; have I mentioned i need to wipe this machine clean?? (Also, the building-supplied WiFi probably just sucks 'cause they'd rather everyone pay for their own in their apartment.) I tried to install it just before writing this; it didn't let me, as there was no device detected. But maybe this driver would, somehow, help you:
http://www.asus.com/us/Networking/USBBT400/HelpDesk_Download/
 
Thread starter Similar threads Forum Replies Date
S Laptop General Discussion 2
S Laptop General Discussion 0
jsimenhoff Laptop General Discussion 30
1 Laptop General Discussion 1
Catdog420 Laptop General Discussion 1
H Laptop General Discussion 1
Y Laptop General Discussion 0
O Laptop General Discussion 1
Zoraver Laptop General Discussion 3
SS98 Laptop General Discussion 2
Ashish27643 Laptop General Discussion 1
Pooya007 Laptop General Discussion 0
SincerelyMe Laptop General Discussion 1
T Laptop General Discussion 4
Kaitalb Laptop General Discussion 1
A Laptop General Discussion 1
A Laptop General Discussion 0
S Laptop General Discussion 1
Firexemblem2 Laptop General Discussion 1
T Laptop General Discussion 1

ASK THE COMMUNITY